Hello Team,

I don't know if you know, jQuery, jQuery UI and jQuery Mobile now use
Grunt [0] as build system. Maybe there are others libs that use it too.

[0] https://github.com/gruntjs/grunt


I intend to package Grunt [1], but there are a lot of dependencies,
about 30. So, I need help to do it. Who can help?

[1] http://bugs.debian.org/673727


There is a big problem, Grunt depends on the JSHint and it is not
DFSG-compatible (Crockford's license) =/

Installing grunt via npm, the following libs were installed as
dependencies:

abbrev
async
buffer-equal
bunker
burrito
bytes
charm
cli
colors
connect
cookie
crc
crc32
dateformat
debug
deep-equal
deflate-js
difflet
eyes
formidable
fresh
glob
glob-whatev
graceful-fs
gzip-js
hooker
inherits
jshint
loggly
lru-cache
mime
minimatch
mkdirp
nodeunit
nopt
package
pause
pkginfo
prompt
qs
range-parser
request
runforcover
semver
send
sigmund
slide
stack-trace
tap
temporary
timespan
traverse
uglify-js
underscore
underscore.string
winston


Some packages are in the Debian repository already, others are not.
I guess the list below are the libs that need be packaged:

abbrev
buffer-equal
bunker
burrito
bytes
charm
cli
cookie
crc
crc32
dateformat
deep-equal
deflate-js
difflet
formidable
fresh
glob-whatev
gzip-js
hooker
jshint
loggly
mkdirp
nodeunit
package
pause
pkginfo
prompt
range-parser
runforcover
send
sigmund
slide
stack-trace
tap
temporary
timespan
underscore.string
winston

        

Cheers,


-- 
Marcelo Jorge Vieira
xmpp:me...@jabber-br.org
http://metaldot.alucinados.com

Attachment: signature.asc
Description: This is a digitally signed message part

_______________________________________________
Pkg-javascript-devel mailing list
Pkg-javascript-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-javascript-devel

Reply via email to