On 13/03/2013 16:45, Dominique Dumont wrote:
> On Wednesday 13 March 2013 16:13:41 Jérémy Lal wrote:
>> Dominique, while it is very nice of you to help,
>> i'm not that happy with these commits : 
> 
> Ah. Sorry about that. I'll try to fix my mess...
> 
>> as you have noticed npm needs
>> dfsg-repackaging, and it was a good occasion to exclude all node_modules.
>> I would have really appreciated you did the same with that upstream update.
> 
> You mean that all node_modules shipped with npm must be removed from upstream 
> tarball ? 

It must decided module by module.
For example proto-list, read, slide were kept in because they really didn't
look like indepently releasable modules.
 
>> It would have been more helpful to ask before doing actual commits.
>> What must be done before this npm update is updating/packaging all its
>> dependencies, meaning packaging first node-gyp and its deps.
> 
> I can try node-gyp. I've found the old repo on collab-maint. Should I update 
> it with node-gyp 0.9.1 ?

I totally forgot i did that myself. Consider almost nothing has been done.

 >> This is
>> where help is needed. Updating npm itself is easy, and i am currently
>> working on nodejs 0.10 update.
>> Also the plan is to upload everything to experimental until wheezy is out,
>> and then to setup a transition to nodejs 0.10 / npm 1.2.
> 
> Sound reasonable.

Thank you a lot for your understanding and your help.
You can reach me on #debian-js if you need.

Jérémy.


_______________________________________________
Pkg-javascript-devel mailing list
Pkg-javascript-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-javascript-devel

Reply via email to