Your message dated Sun, 28 Apr 2013 19:32:43 +0000
with message-id <e1uwxl1-00040v...@franck.debian.org>
and subject line Bug#705236: fixed in npm 1.2.18~dfsg-1
has caused the Debian Bug report #705236,
regarding npm doesn't work with node v0.10.1
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
705236: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=705236
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Package: npm
Version: 1.1.4~dfsg-2
Severity: normal

Dear Maintainer,

I just had a nodejs application which was not compatible with nodejs 0.6
anymore and thus had to upgrade to 0.10 from experimental.

Though it seems npm from debian does not work on nodejs from experimental.

Error: npm doesn't work with node v0.10.1
Required: node@0.6 || 0.7 || 0.8
    at /usr/share/npm/bin/npm-cli.js:67:23
    at Object.<anonymous> (/usr/share/npm/bin/npm-cli.js:87:3)
    at Module._compile (module.js:456:26)
    at Object.Module._extensions..js (module.js:474:10)
    at Module.load (module.js:356:32)
    at Function.Module._load (module.js:312:12)
    at Function.Module.runMain (module.js:497:10)
    at startup (node.js:119:16)
    at node.js:901:3

ps.: node v0.10.3 with included npm works.

Michael Gebetsroither

-- System Information:
Debian Release: squeeze/sid
  APT prefers unstable
  APT policy: (990, 'unstable'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 3.5-trunk-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages npm depends on:
ii  node-abbrev       1.0.3-1
ii  node-fstream      0.1.13-1
ii  node-graceful-fs  1.1.8-1
ii  node-ini          1.0.2-1
ii  node-minimatch    0.2.0-1
ii  node-mkdirp       0.3.1-2
ii  node-node-uuid    1.3.3-1
ii  node-nopt         1.0.10-2
ii  node-request      2.9.153-1
ii  node-rimraf       2.0.1-1
ii  node-semver       1.0.13-2
ii  node-tar          0.1.13-1
ii  node-which        1.0.5-2
ii  nodejs            0.10.1~dfsg1-2
ii  nodejs-dev        0.10.1~dfsg1-2

npm recommends no packages.

Versions of packages npm suggests:
ii  build-essential  11.5

-- no debconf information

--- End Message ---
--- Begin Message ---
Source: npm
Source-Version: 1.2.18~dfsg-1

We believe that the bug you reported is fixed in the latest version of
npm, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 705...@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Jérémy Lal <kapo...@melix.org> (supplier of updated npm package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmas...@debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

Format: 1.8
Date: Sun, 28 Apr 2013 21:03:50 +0200
Source: npm
Binary: npm
Architecture: source all
Version: 1.2.18~dfsg-1
Distribution: experimental
Urgency: low
Maintainer: Debian Javascript Maintainers 
<pkg-javascript-devel@lists.alioth.debian.org>
Changed-By: Jérémy Lal <kapo...@melix.org>
Description: 
 npm        - package manager for Node.js
Closes: 695821 705236
Changes: 
 npm (1.2.18~dfsg-1) experimental; urgency=low
 .
   * New upstream release. (Closes: #695821, #705236)
   * debian/patches:
     + refresh
     + remove upstream patches.
   * debian/control:
     + update dependencies on external node-* modules
     + tighten dependencies on modules that are available in unstable
       and experimental, only when required by npm package.json.
     + remove DMUA field.
     + no longer Suggests: build-essential, since building is handled by
       node-gyp, not directly by npm.
   * debian/copyright:
     + update sections to match required modules,
     + update the list of excluded files,
     + comment why some modules are kept inside npm
   * debian/watch: fix again.
Checksums-Sha1: 
 04a0da60ce056d708ab5ee86568ed42bc2e286dd 2003 npm_1.2.18~dfsg-1.dsc
 fc3dc13accdaa35f99152db0ad4c128b0a653e0a 936025 npm_1.2.18~dfsg.orig.tar.gz
 1ae73fdeb28bd89d1ddd9dc617d80642a47a31be 13630 npm_1.2.18~dfsg-1.debian.tar.gz
 1cb0418016d23347f6839bcf2e88b727c9cf3a37 432644 npm_1.2.18~dfsg-1_all.deb
Checksums-Sha256: 
 4833e2291daef6a79df84e32f16996f0cc44effc36699429e1bd61bec0c75518 2003 
npm_1.2.18~dfsg-1.dsc
 dfe8e3ea2fb40ae4e9c4ab63029d777be55490bf12cab75841f407cf8fe9c949 936025 
npm_1.2.18~dfsg.orig.tar.gz
 d467533ebb6773605791601601d26582bd6335098553b3b86ca3557727c2b253 13630 
npm_1.2.18~dfsg-1.debian.tar.gz
 e46b19f9a6a48e64a821e41cd4af4bc020989646a1876cb5ea5cd6f0136d24a2 432644 
npm_1.2.18~dfsg-1_all.deb
Files: 
 634eb3fb793c229dd31a5fed3e629bdd 2003 web extra npm_1.2.18~dfsg-1.dsc
 6be4dbf87414f8e105302a91d7ca5189 936025 web extra npm_1.2.18~dfsg.orig.tar.gz
 592f379e42f59008ab0ac3c1faf31891 13630 web extra 
npm_1.2.18~dfsg-1.debian.tar.gz
 08addeae245a366b48aefbddd90584e1 432644 web extra npm_1.2.18~dfsg-1_all.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.12 (GNU/Linux)

iQIcBAEBCAAGBQJRfXYvAAoJEGYRwF7dOfN05TIP/An5JmWCqpc+jO+MGgSvXqwc
Er+8sx6QxcZD0JVdjfStV0ZmYgALGdRzlnjgeogu1LhCremfMlcp5SWqCgk7Rn5F
pVDUF3h2OWGJCVVVn7jgJY3xSb+P8xWOwU/yRQBDk/UfCmTQqr371qUToePdWOJz
WVYJWbu0FAX606UnvKi7acdG+w80j4+/Gti7ZJrgP+DX5tlZXXpQ/IXhKwpiPe7B
5Rzx/YPEgucpXbQieSWXXMewyvnmcLKyA0tlPMMfBu4O/DdF7tqt3ox1XfYSKgkm
Zg4Jht3qM6xjTPfBe9ZXm/o+YyUb+u8wk2qHIuyONTm9XhFpf32sx2T5I6W/2hkb
n7J0f167hNzfC1He5EkYHSCnZvdHqJq08aMTYcMpb+JX1uwKYlwUakAbeTFFWEaZ
dN1bDxlggBz32USDRxiahMLO0Xkupok9jHRJFN/n2d24g6ISfUkuI2DoEF/nyBB6
qlZtgppI4lAudMuVfqeH/aRVEIBbzg45tBZ0KnpwzZmyilLoAsAAxE+kJFQbCcKx
0lHOaO00+Tsp4fFS0F5NmlxlejLdVXbkFXtYv+Tlc+uuV7DRHtcOtR4RWPBfHCFb
8Eikku+IQ8nBna7T9y35wSr8XOJ7YGgIdoUEVxZtftqZ2soBVsxur+VPOcl5/i9J
WXMOkVnHiPDwLas8/tqy
=uRB1
-----END PGP SIGNATURE-----

--- End Message ---
_______________________________________________
Pkg-javascript-devel mailing list
Pkg-javascript-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-javascript-devel

Reply via email to