Package: npm
Version: 1.1.4~dfsg-2
Severity: normal

Dear Maintainer,

I tried to install Bower, but it wasn't able to display any installable

-- System Information:
Debian Release: jessie/sid
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 3.10-2-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages npm depends on:
ii  node-abbrev       1.0.3-1
ii  node-fstream      0.1.13-1
ii  node-graceful-fs  1.1.8-1
ii  node-ini          1.1.0-1
ii  node-minimatch    0.2.0-1
ii  node-mkdirp       0.3.1-2
ii  node-node-uuid    1.4.0-1
ii  node-nopt         1.0.10-1
ii  node-request      2.9.153-1
ii  node-rimraf       2.0.1-1
ii  node-semver       2.1.0-2
ii  node-tar          0.1.13-1
ii  node-which        1.0.5-2
ii  nodejs            0.6.19~dfsg1-5ubuntu1
ii  nodejs-dev        0.6.19~dfsg1-5ubuntu1

npm recommends no packages.

Versions of packages npm suggests:
pn  build-essential  <none>

-- no debconf information
info it worked if it ends with ok
verbose cli [ '/usr/bin/nodejs', '/usr/bin/npm', 'install', '--save', 'bower' ]
info using npm@1.1.4
info using node@v0.6.19
verbose config file /root/.npmrc
verbose config file /usr/etc/npmrc
verbose config file /usr/share/npm/npmrc
verbose cache add [ 'bower', null ]
silly cache add: name, spec, args [ undefined, 'bower', [ 'bower', null ] ]
verbose parsed url { pathname: 'bower', path: 'bower', href: 'bower' }
verbose addNamed [ 'bower', '' ]
verbose addNamed [ null, '*' ]
silly name, range, hasData [ 'bower', '*', false ]
verbose raw, before any munging bower
verbose url resolving [ '', './bower' ]
verbose url resolved
verbose etag "YP8DPYWZ17FUT7R0I2F4RF6Y"
http GET
http 304
silly get cb [ 304,
silly get cb   { server: 'CouchDB/1.3.1 (Erlang OTP/R15B03)',
silly get cb     etag: '"YP8DPYWZ17FUT7R0I2F4RF6Y"',
silly get cb     date: 'Mon, 26 Aug 2013 13:58:30 GMT',
silly get cb     'content-length': '0' } ]
verbose etag bower from cache
silly name, range, hasData 2 [ 'bower', '*', true ]
silly versions [ 'bower', [] ]
ERR! Error: No compatible version found: bower@'*'
ERR! No valid targets found.
ERR! Perhaps not compatible with your version of node?
ERR!     at installTargetsError (/usr/share/npm/lib/cache.js:488:10)
ERR!     at next_ (/usr/share/npm/lib/cache.js:438:17)
ERR!     at next (/usr/share/npm/lib/cache.js:415:44)
ERR!     at /usr/share/npm/lib/cache.js:408:5
ERR!     at saved (/usr/share/npm/lib/utils/npm-registry-client/get.js:147:7)
ERR!     at Object.oncomplete (/usr/lib/nodejs/graceful-fs.js:230:7)
ERR! You may report this log at:
ERR!     <>
ERR! or use
ERR!     reportbug --attach /home/orangensaft/npm-debug.log npm
ERR! System Linux 3.10-2-amd64
ERR! command "/usr/bin/nodejs" "/usr/bin/npm" "install" "--save" "bower"
ERR! cwd /home/orangensaft
ERR! node -v v0.6.19
ERR! npm -v 1.1.4
ERR! message No compatible version found: bower@'*'
ERR! message No valid targets found.
ERR! message Perhaps not compatible with your version of node?
verbose exit [ 1, true ]
Pkg-javascript-devel mailing list

Reply via email to