Your message dated Sat, 01 Mar 2014 03:21:45 +0000
with message-id <e1wjauj-0008i0...@franck.debian.org>
and subject line Bug#672388: fixed in npm 1.4.4+ds-1
has caused the Debian Bug report #672388,
regarding npm: completion in Zsh causes error message regarding missing 
/usr/share/npm/lib/utils/completion.sh
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
672388: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=672388
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Package: npm
Version: 1.1.4~dfsg-1
Severity: normal


I'm using Zsh:

% zsh --version
zsh 4.3.17 (x86_64-unknown-linux-gnu)

which provides a completion in its package
(/usr/share/zsh/functions/Completion/Unix/_npm), but
there seems to be something fishy in the npm package.

When I press the tab key after 'npm ' then I get:

| % npm 
| npm ERR! Error: ENOENT, open '/usr/share/npm/lib/utils/completion.sh'
| npm ERR! You may report this log at:
| npm ERR!     <http://bugs.debian.org/npm>
| npm ERR! or use
| npm ERR!     reportbug --attach /home/mika/npm-debug.log npm
| npm ERR!
| npm ERR! System Linux 3.2.0-1-grml-amd64
| npm ERR! command "node" "/usr/bin/npm" "completion" "--color" "false" 
"--loglevel" "error" "--" "npm"
| npm ERR! cwd /home/mika
| npm ERR! node -v v0.6.17
| npm ERR! npm -v 1.1.4
| npm ERR! path /usr/share/npm/lib/utils/completion.sh
| npm ERR! code ENOENT
| npm ERR! message ENOENT, open '/usr/share/npm/lib/utils/completion.sh'
| npm ERR! errno {}
| npm ERR!
| npm ERR! Additional logging details can be found in:
| npm ERR!     /home/mika/npm-debug.log


This is the same output I also get when manually running the command
/usr/share/zsh/functions/Completion/Unix/_npm uses:

| % npm completion --color false --loglevel error --
| [<snip same message as above>]

Regarding /usr/share/npm/lib/utils/completion.sh - this file doesn't
exist:

% ls -la /usr/share/npm/lib/utils/completion.sh
ls: cannot access /usr/share/npm/lib/utils/completion.sh: No such file or 
directory

regards,
-mika-



--- End Message ---
--- Begin Message ---
Source: npm
Source-Version: 1.4.4+ds-1

We believe that the bug you reported is fixed in the latest version of
npm, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 672...@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Jérémy Lal <kapo...@melix.org> (supplier of updated npm package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmas...@ftp-master.debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

Format: 1.8
Date: Sat, 01 Mar 2014 02:57:59 +0100
Source: npm
Binary: npm
Architecture: source all
Version: 1.4.4+ds-1
Distribution: unstable
Urgency: medium
Maintainer: Debian Javascript Maintainers 
<pkg-javascript-devel@lists.alioth.debian.org>
Changed-By: Jérémy Lal <kapo...@melix.org>
Description: 
 npm        - package manager for Node.js
Closes: 672388 740338
Changes: 
 npm (1.4.4+ds-1) unstable; urgency=medium
 .
   * New upstream release. (Closes: #740338)
   * Repackaging is no longer DFSG-needed, now only used to ease
     copyright maintenance.
   * Switch to uscan and debian/copyright Files-Excluded field for
     repackaging upstream tarball. Drop usage of cdbs upstream-tarball.
   * Install completion.sh (Closes: #672388)
   * Convenient removal of ansicolors, ansistyles, text-table.
     Instead, depend on node-ansi-color-table and add 2009 patch.
   * copyright:
     + npm copyright holder changed to npm, inc.
     + switch read-installed, promzard, uid-number to ISC license
     + add sections for path-is-inside,
       github-url-from-username-repo, npm-install-checks, columnify
     + remove couch-login section (no longer included)
Checksums-Sha1: 
 4cfe566c3224e775f0266f4a8b27c954887f2a01 1960 npm_1.4.4+ds-1.dsc
 63ea24d834220a33a149863d838f44a5675a781c 936062 npm_1.4.4+ds.orig.tar.gz
 9cfd863a8193364435689aeb26faa6a18db43079 16932 npm_1.4.4+ds-1.debian.tar.xz
 6a3489f888239da2d97f29d8df7dc0c7718af919 322584 npm_1.4.4+ds-1_all.deb
Checksums-Sha256: 
 9c45b5c83ddf33d816e6b8e0ebb3ca0ff6dffcef3e7c4c31d9d1a63b50eaa800 1960 
npm_1.4.4+ds-1.dsc
 31fd615015982db26c04e693c5db1e9d65f84d886c55f1e87c33af3654faa59f 936062 
npm_1.4.4+ds.orig.tar.gz
 895317b18cd9587246d08715b9268d53049982b8ade4246d612e45c44c9da5fe 16932 
npm_1.4.4+ds-1.debian.tar.xz
 0f3d8925343f9a228804ad5159ca567769f086a51fb8647c6974465433b2b6f1 322584 
npm_1.4.4+ds-1_all.deb
Files: 
 cbc649417c565b49e01bf67bc41e8478 1960 web extra npm_1.4.4+ds-1.dsc
 be12708dbbc0be6820c07121f6341a93 936062 web extra npm_1.4.4+ds.orig.tar.gz
 121bc2e192e56320e5572c0e602b45aa 16932 web extra npm_1.4.4+ds-1.debian.tar.xz
 a3687033631cd570b2c9477d3df8eef9 322584 web extra npm_1.4.4+ds-1_all.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iQIcBAEBCAAGBQJTET7kAAoJEGYRwF7dOfN0Wt0QAKbSK9pCKYitvVPAFrs5Redp
VIZ6pNEsJLaLPYXdVL3eydZuVIoJx/GkStodgtl4C7rU68Io+pnu9OJZSaXmP+8A
rXkTQXGRIoOBA4d0wLwiY/4CXq6hrxVhXGkdkBWh2aF/HtCJRy7nslYifQlJW3O7
SXj/e1vXp/FVcd0X+7fB+8vpQKYdBf6D/Lc8VHMWwCSiQ97rAFqz3Y5n01sEcP3x
sMkKM4NLxxvuwh+8Kp4TjEyseVqau9JxGMzEOm+/406jPztVe7794SmiRHxHrPaN
nMItkNK+adJ4Y0rlb+dfkVc5H2YUE55muxURLzMrax+ZkMrksZFDRi+2UEu9rwZe
JrM/psImREQqUEoMhfcC0ZCs+IiiyAZ1EJsDY9ldA/xkPboDZZPzZRc3xXorDR4X
/A/IJuoJnfENBs8liFuwjVDHa38OL/cLTLExLhEPFlQZEgDBXtt/kYRisxYBORhF
6MBIGziv/XWBk26vWMaYcjlVPzBquilPU4TcW4eoyX4fDS/cCFtLUGB+TQPJ4eXC
i4UGWPO1caNsI/HIhRCPPsxIu93AK4oiLj4ocsndnjHUQ2kiqWmJ6pcXwFHYciHO
cJh7h00zB+RgDc6ZTftpPYxQm55bpbr18U4MmlhZ98oIsByFEFYulzlLlbhGS2vM
NWSsGE+E42Nj6Pl8bmq+
=YBqY
-----END PGP SIGNATURE-----

--- End Message ---
_______________________________________________
Pkg-javascript-devel mailing list
Pkg-javascript-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-javascript-devel

Reply via email to