Package: node-peg
Severity: important

Dear Maintainer,

You are installing files in:
 /usr/lib/nodejs/peg-js/

while, according with package.json (name field), correct path should be:
 
 /usr/lib/nodejs/pegjs/

This is not only related to path name, but also on call it as
dependency.

In fact, this command fails:
  require('pegjs');

According with Policy, even binary package name should be renamed to node-pegjs.
 https://wiki.debian.org/Javascript/Nodejs/Manual

Leo.


Best,

Leo. 

-- System Information:
Debian Release: jessie/sid
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 3.13.0-24-generic (SMP w/4 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

_______________________________________________
Pkg-javascript-devel mailing list
Pkg-javascript-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-javascript-devel

Reply via email to