Your message dated Fri, 16 May 2014 16:15:23 +0000
with message-id <e1wlkn5-0006j6...@franck.debian.org>
and subject line Bug#747654: fixed in node-iscroll 5.1.1+dfsg1-2
has caused the Debian Bug report #747654,
regarding Error: Cannot find module 'iscroll'
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
747654: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=747654
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Source: node-iscroll
Severity: important

Dear Maintainer,

ting your module as:

nodejs -e "require('iscroll');"

It fails and return:


module.js:340
    throw err;
          ^
Error: Cannot find module 'iscroll'
    at Function.Module._resolveFilename (module.js:338:15)
    at Function.Module._load (module.js:280:25)
    at Module.require (module.js:364:17)
    at require (module.js:380:17)
    at [eval]:1:1
    at Object.<anonymous> ([eval]-wrapper:6:22)
    at Module._compile (module.js:456:26)
    at evalScript (node.js:532:25)
    at startup (node.js:80:7)
    at node.js:902:3


It seems you are missing a symlink:

/usr/lib/nodejs/iscroll/index.js -> /usr/lib/nodejs/iscroll/iscroll.js


Moreover, it should not Recommds javascript-common (useless for
node-modules).

Regards,

Leo.


-- System Information:
Debian Release: jessie/sid
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 3.13.0-24-generic (SMP w/4 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

--- End Message ---
--- Begin Message ---
Source: node-iscroll
Source-Version: 5.1.1+dfsg1-2

We believe that the bug you reported is fixed in the latest version of
node-iscroll, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 747...@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Balint Reczey <bal...@balintreczey.hu> (supplier of updated node-iscroll 
package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmas...@ftp-master.debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Fri, 11 Apr 2014 13:30:20 +0200
Source: node-iscroll
Binary: libjs-iscroll node-iscroll
Architecture: source all
Version: 5.1.1+dfsg1-2
Distribution: unstable
Urgency: low
Maintainer: Debian Javascript Maintainers 
<pkg-javascript-devel@lists.alioth.debian.org>
Changed-By: Balint Reczey <bal...@balintreczey.hu>
Description: 
 libjs-iscroll - High performance, small footprint JavaScript scroller
 node-iscroll - High performance, small footprint JavaScript scroller
Closes: 747654
Changes: 
 node-iscroll (5.1.1+dfsg1-2) unstable; urgency=low
 .
   [ Leo Iannacone ]
   * Fix finding iscroll module from nodejs.
     It can't be loaded to nodejs however, since iScroll needs to be run
     in a browser window. It can be used from Browserify. (Closes: #747654)
   * Stop node-iscroll uselessly recommending javascript-common
 .
   [ Balint Reczey ]
   * Fix FTBFS with Make 4
Checksums-Sha1: 
 a731669c8bf8534a15761f7525d631ea79a80bb3 2073 node-iscroll_5.1.1+dfsg1-2.dsc
 e546b3d5eab3ad40ac4b329b17016a7c961f9d80 3544 
node-iscroll_5.1.1+dfsg1-2.debian.tar.xz
 e313c1578c816c64cd4636cf338785b315cc1fcd 223018 
libjs-iscroll_5.1.1+dfsg1-2_all.deb
 ef1ed2871524233a67ae9075f20ffe3f7e5d692f 21328 
node-iscroll_5.1.1+dfsg1-2_all.deb
Checksums-Sha256: 
 fdee0b970130463495719f2189b6b4e19ea7a6f7913b6b29e26276ef3c28905e 2073 
node-iscroll_5.1.1+dfsg1-2.dsc
 e9b137679cc3e7466606037d5051b6500061ad352bede4e6e7eb415585737d51 3544 
node-iscroll_5.1.1+dfsg1-2.debian.tar.xz
 f2fa0e0f2d34260d1c760669406714f22d8658cac967c753924bd5a5d4822986 223018 
libjs-iscroll_5.1.1+dfsg1-2_all.deb
 7a8f05731acbb69cf641309a988865f74578e9590fcce75bdd81fea8967aac72 21328 
node-iscroll_5.1.1+dfsg1-2_all.deb
Files: 
 57b646e646caec46e3c7bb0cc80ac967 223018 web optional 
libjs-iscroll_5.1.1+dfsg1-2_all.deb
 6f10d42b9f9ba915409592b73082b415 21328 web optional 
node-iscroll_5.1.1+dfsg1-2_all.deb
 92b11158d9e2670e1d70324dcdf0ae10 2073 web optional 
node-iscroll_5.1.1+dfsg1-2.dsc
 ee48224a16c7eaad8bb2c388d4e8a2f4 3544 web optional 
node-iscroll_5.1.1+dfsg1-2.debian.tar.xz

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.12 (GNU/Linux)

iQIcBAEBAgAGBQJTdjHeAAoJEPZk0la0aRp9CG0P/2ugHVeUCLw7VZbmyfxtf2ps
mWhaHI+I1WI/ZWnoBm9n8oP5JQ9SUVSSWBKQOZ2AnTerMiAenvkoUdTUDIqxeejy
nNPw/9kd9AUjLi4YUsvIJocqm6/Gip7qqhgBW/6Twyp7FZjpiNep9gk/u/v3AXUu
RrXMrfTpPAubOQ9jdX4sN6d4T+8B4DBa+xXXJ72EInpHvO8Izg6oyNlbGEKJwSKs
T3I4DS9/W9XjGaH1huKaJ4q+lq4xoNQ3iCK6AOV4+QTJzyU+XQiDKvp7tHnnQxbz
shhQ1oDIn0EBQaIr/kkFWjikQbtsZIL16K6L4Dw0XIRIrtn4HAWytUFo0VvbW9ze
w/kkFv9hTvSJDLPEgUciLDw1StdNFbM5N0Nr4xVy/1Fqm/FbN6wg40EjofMN6vFN
z+zweo45CuSj304pwli6ah1ZTBgxrB5BeVjfSfPsqT2HQIj1uH0IOmLqeUqeAGLf
JrUixS30X2Fw37ROBJ3/HexmkrYQiOD7QfpF5RqlBPOcoEhGYjwk9/y6A3f2GVEN
kVWN+LZqi3/qYs95QixZNJB8WvnQupZDCU2kTAySYHG/+6c3Bt72W/Dd4uxsDFZ+
Dm+Sb0K7kZb7JPnSWl1l89/jbCl1V8LpQr3bha2JboaVSNIPEBRdP+ZZaEWKinfc
U7xX4mKGVRMg2V54JjOU
=NUa3
-----END PGP SIGNATURE-----

--- End Message ---
_______________________________________________
Pkg-javascript-devel mailing list
Pkg-javascript-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-javascript-devel

Reply via email to