Package: wnpp
Severity: wishlist

* Package name    : node-uglifyjs2
  Version         : 2.4.15
  Upstream Author : Mihai Bazon <mihai.ba...@gmail.com>
* URL             : https://github.com/mishoo/UglifyJS2
* License         : BSD
  Programming Lang: JS
  Description     : JavaScript parser, minifier, compressor and beautifier
toolkit

>From the UglifyJS (version 1.x) README:
I started working on UglifyJS’s successor, version 2. It’s almost a full
rewrite (except for the parser which is heavily modified, everything else
starts from scratch). I’ve detailed my reasons in the README, see the project
page. ... Version 1 will continue to be maintained for fixing show-stopper
bugs, but no new features should be expected.

It sounds like UglifyJS2 should be created as a new package instead of updating
the current node-uglify.

Note that UglifyJS2 is required for ruby-uglifier. Right now, ruby-uglifier
contains an embedded version of uglify 2.4.15, which violates policy 4.13
(Convenience copies of code).

Thanks,
Caitlin

_______________________________________________
Pkg-javascript-devel mailing list
Pkg-javascript-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-javascript-devel

Reply via email to