Hi Jérémy,

On 09/08/2014 06:59 PM, Jérémy Lal wrote:
> Le lundi 08 septembre 2014 à 18:44 -0300, Breno Leitao a écrit :
>> Package: nodejs
>> Version: 0.10.29~dfsg-1
>> Severity: normal
>>
>> Hi,
>>
>> I would like to enable nodejs to build for ppc64el. It was ported and the
>> upstream process is still in progress.
>>
>> For now, the patches are at https://github.com/andrewlow/node.
>>
>> So, the next step here is to attach a patch that applies smoothly to Debian's
>> nodejs. Any concern about it?
> 
> Apart from the fact nodejs build-depends on libv8-3.14, which is not
> ppc64el enabled (yet).
Right. I will create a bug with the pathes also.

> The reason why libv8-3.14 ppc patch wasn't applied is because ppc
> architecture supports too old processors and the v8 ppc port was not
> compatible with those.
sure.

> Obviously that problem isn't going to happen with ppc64el.
> 
> I'll happily accept patches to v8-3.14/nodejs.
> Are you able to make sure the test suites pass, please ?
Sure. We have it running and built on Ubuntu since 14.04, so. it is not a 
problem.

Thank you,
Breno

_______________________________________________
Pkg-javascript-devel mailing list
Pkg-javascript-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-javascript-devel

Reply via email to