Quoting intrigeri (2014-11-15 16:38:18)
> Andrey Rahmatullin wrote (12 Nov 2014 18:20:30 GMT) :
>> On Sun, Nov 09, 2014 at 06:10:57PM +0100, Felix Gruber wrote:
>>> phantomjs is currently not in jessie due to two RC bugs (#679759 and
>>> #699435).
>> ... and thus it won't be in jessie at all.
>
> wordpress build-depends on libjs-backbone (built by the backbone
> source package) which itself build-depends on phantomjs.
>
> phantomjs was removed from testing more that two years ago. It has 
>
>   * an open security issue (CVE-2013-4549)
>   * FTBFS on kfreebsd (#679759, which isn't RC anymore)
>   * so many embedded code copies (#699435) that the security team
>     doesn't want to see it in a stable release "as long as it's using
>     a copy of QT"
>
> I don't see how we can fix this situation in time for Jessie.
>
> How important is wordpress' build-dependency on libjs-backbone?
> Can it be removed?

backbone uses phantomjs only for improved regression testing, so I 
believe the better workaround is to simply drop that build-dependency 
for Jessie.

I will look into that shortly...

 - Jonas

-- 
 * Jonas Smedegaard - idealist & Internet-arkitekt
 * Tlf.: +45 40843136  Website: http://dr.jones.dk/

 [x] quote me freely  [ ] ask before reusing  [ ] keep private

Attachment: signature.asc
Description: signature

_______________________________________________
Pkg-javascript-devel mailing list
Pkg-javascript-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-javascript-devel

Reply via email to