Your message dated Sun, 10 May 2015 18:03:29 +0200
with message-id 
<cajxtcxw4k32jeutdsb4b49aidg9tnv-icw081xiywuz_vo4...@mail.gmail.com>
and subject line Re: Bug#784892: [Pkg-javascript-devel] Bug#784892: npm ERR! 
Couldn't read dependencies.
has caused the Debian Bug report #784892,
regarding npm ERR! Couldn't read dependencies.
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
784892: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=784892
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Package: npm
Version: 1.1.4~dfsg-2
Severity: normal

Dear Maintainer,
*** Please consider answering these questions, where appropriate ***

   * What led up to the situation?
   * What exactly did you do (or not do) that was effective (or
     ineffective)?
   * What was the outcome of this action?
   * What outcome did you expect instead?

*** End of the template - remove these lines ***


-- System Information:
Debian Release: 7.6
Architecture: armhf (armv6l)

Kernel: Linux 3.12.35+ (PREEMPT)
Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages npm depends on:
ii  node-abbrev       1.0.3-1
ii  node-fstream      0.1.13-1
ii  node-graceful-fs  1.1.8-1
ii  node-ini          1.0.2-1
ii  node-minimatch    0.2.0-1
ii  node-mkdirp       0.3.1-2
ii  node-node-uuid    1.2.0~20110510-2
ii  node-nopt         1.0.10-2
ii  node-request      2.9.153-1
ii  node-rimraf       2.0.1-1
ii  node-semver       1.0.13-2
ii  node-tar          0.1.13-1
ii  node-which        1.0.5-1
ii  nodejs            0.6.19~dfsg1-6
ii  nodejs-dev        0.6.19~dfsg1-6

npm recommends no packages.

Versions of packages npm suggests:
ii  build-essential  11.5+b1

Append:
complete error on console:
pi@raspberrypi ~ $ npm install
npm ERR! Couldn't read dependencies.

npm ERR! Error: ENOENT, open '/home/pi/package.json'
npm ERR! You may report this log at:
npm ERR!     <http://bugs.debian.org/npm>
npm ERR! or use
npm ERR!     reportbug --attach /home/pi/npm-debug.log npm
npm ERR!
npm ERR! System Linux 3.12.35+
npm ERR! command "/usr/bin/nodejs" "/usr/bin/npm" "install"
npm ERR! cwd /home/pi
npm ERR! node -v v0.6.19
npm ERR! npm -v 1.1.4
npm ERR! path /home/pi/package.json
npm ERR! code ENOENT
npm ERR! message ENOENT, open '/home/pi/package.json'
npm ERR! errno {}
npm ERR!
npm ERR! Additional logging details can be found in:
npm ERR!     /home/pi/npm-debug.log
npm not ok


-- no debconf information

--- End Message ---
--- Begin Message ---
>
> 2015-05-10 11:14 GMT+02:00 Jérémy Lal <kapo...@melix.org>:
>
>> 2015-05-10 10:38 GMT+02:00 Francisco <fdominguezro...@gmail.com>:
>>
>>> Package: npm
>>> Version: 1.1.4~dfsg-2
>>> Severity: normal
>>>
>>> Debian Release: 7.6
>>> Architecture: armhf (armv6l)
>>>
>>
>>
>> It seems you typed "npm install" in a directory that has no package.json.
>> Please read `man npm install`.
>>
>> If you don't provide more information i'll close this bug.
>>
>> Side note: I suggest you upgrade to debian jessie 8.0, where npm is a
>> bit more
>> up-to-date and known to be working.
>>
> 2015-05-10 12:08 GMT+02:00 Francisco Domínguez Román <
fdominguezro...@gmail.com>:

> Thanks everything solved after cleaning up my install. Thanks!
>
>
Closing, then.

--- End Message ---
_______________________________________________
Pkg-javascript-devel mailing list
Pkg-javascript-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-javascript-devel

Reply via email to