Source: node-topcube
Severity: important
Tags: sid stretch
Usertags: oldlibs libwebkitgtk-1.0-0 webkit1


node-topcube depends on libwebkitgtk-1.0-0, which is deprecated in
favor of libwebkit2gtk-4.0-37. node-topcube should be ported to the
new webkitgtk version so we can remove the old, unmaintained one.

As an intermediate step you can port node-topcube to
libwebkitgtk-3.0-0, which has a similar API to libwebkitgtk-1.0-0 but
is based on GTK+ 3.0. Thus you'd be porting node-topcube to GTK+ 3.0
first, using libwebkitgtk-3.0-0, and you could then port to
libwebkit2gtk-4.0-37 later. But note that libwebkitgtk-3.0-0 is also

Please try to do this before the Stretch release as we're going to
try to remove libwebkitgtk-1.0-0 this cycle.

We'll bump this to serious when the list of rdeps is small and we're
getting ready to removing libwebkitgtk-1.0-0 completely.

If you have any question don't hesitate to ask.


Pkg-javascript-devel mailing list

Reply via email to