Hi Antonio,

On Fri Aug 21 19:47:13 2015 Antonio Terceiro <terce...@debian.org> wrote:
> On Wed, Jul 29, 2015 at 05:20:43PM +0000, Mike Gabriel wrote:
> > Hi Jonas,
> > 
> > On   Mi 29 Jul 2015 09:18:39 CEST, Jonas Smedegaard wrote:
> > 
> > > Quoting Mike Gabriel (2015-07-29 01:33:43)
> > > > On   Di 28 Jul 2015 20:45:45 CEST, Matt Taggart wrote:
> > > > > I also need jquery updated in order to fix #792451.
> > > > > 
> > > > > Lots of upstream maintainers seem to embed copies of jquery, if
> > > > > we don't provide a recent packaged version this is going to turn
> > > > > into a security nightmare...
> > > > 
> > > > by coincidence, I have today started looking at jquery-ui (and
> > > > jquery-ui-themes) which needs to be updated in Debian in order to
> > > > get the e-Learning portal ILIAS into Debian.
> > > > 
> > > > I also vote for getting jquery updated in Debian, maybe to
> > > > experimental first, so people can test compatibility(?!?).
> > > > 
> > > > I am happy to continue working on jquery-ui, maybe someone else
> > > > wants to pick up jquery itself? Obviously, the previous maintainer
> > > > has not work on jquery(-ui) in Debian since 2013 or so, right?
> > > 
> > > Yes, previous maintainer evidently is too busy elsewhere currently,
> > > but there's no dispute (that I am aware) so voting doesn't help.
> > > Instead, someone needs to step up and join the maintenance of jquery.
> > > 
> > > Since you are interested in the quite related jquery-ui, perhaps you
> > > could also help with jquery?
> > > 
> > > (I have little interest in jquery-based code myself)
> > > 
> > > - Jonas
> > 
> > I will take a look into jquery, as well, unless someone else jumps up.
> 
> I gave it a try and was able to get it working locally. I have just
> requested membership to the JS team to maintain it. (I still don't know
> how crazy I am being here ...)

Great! The first upload (to exp) should bring the latest upstream to Debian.

Once that version gets re-uploaded to unstable, we should prepare versioned 
packages (jquery-X.Y, same for jquery-ui). So that it is possible to install 
several jquery(-ui) versions in parallel.

Good to have you joining in!!!
Mike


-- 

DAS-NETZWERKTEAM
mike gabriel, herweg 7, 24357 fleckeby
fon: +49 (1520) 1976148

GnuPG Key ID 0x25771B13
mail: mike.gabr...@das-netzwerkteam.de, http://das-netzwerkteam.de

_______________________________________________
Pkg-javascript-devel mailing list
Pkg-javascript-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-javascript-devel

Reply via email to