Package: libjs-chosen
Version: 0.9.11-2
Severity: important
Tags: upstream

The $.browser map is removed in jQuery 1.9. With the update of libjs-jquery 
from 1.7.2 to 1.11.3, chosen no longer works. The browser console shows this 
message:

 TypeError: $.browser is undefined    chosen.jquery.js:309:0

The jQuery documentation recommends using feature detection instead of browser 
checks.

I haven't checked whether the new upstream release (1.4.2) fixes this.


Cheers,
    dam

-- System Information:
Debian Release: stretch/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (1, 'experimental')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 4.1.0-2-amd64 (SMP w/4 CPU cores)
Locale: LANG=bg_BG.UTF-8, LC_CTYPE=bg_BG.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

-- no debconf information

_______________________________________________
Pkg-javascript-devel mailing list
Pkg-javascript-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-javascript-devel

Reply via email to