Your message dated Sat, 19 Sep 2015 19:07:49 +0000
with message-id <e1zdnud-0006sn...@franck.debian.org>
and subject line Bug#799446: fixed in libuv1 1.7.4-2
has caused the Debian Bug report #799446,
regarding libuv1: missing symbols on kfreebsd
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
799446: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=799446
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Package: libuv1
Version: 1.7.4-1
Severity: normal

Hello,

the build log says it all
https://buildd.debian.org/status/fetch.php?pkg=libuv1&arch=kfreebsd-amd64&ver=1.7.4-1&stamp=1442261460

and when trying to link nodejs against libuv1 1.7.4 i get:

  g++ -pthread -rdynamic -m64 -Wl,--export-dynamic -Wl,-z,relro -o 
/home/kapouer/nodejs/out/Release/cctest -Wl,--start-group 
/home/kapouer/nodejs/out/Release/obj.target/cctest/test/cctest/util.o 
/home/kapouer/nodejs/out/Release/obj.target/deps/gtest/libgtest.a 
/home/kapouer/nodejs/out/Release/obj.target/deps/v8/tools/gyp/libv8_libplatform.a
 /home/kapouer/nodejs/out/Release/obj.target/deps/v8/tools/gyp/libv8_base.a 
/home/kapouer/nodejs/out/Release/obj.target/deps/v8/tools/gyp/libv8_libbase.a 
/home/kapouer/nodejs/out/Release/obj.target/deps/v8/tools/gyp/libv8_nosnapshot.a
 -Wl,--end-group -lz -luv -lrt -lpthread -lnsl -lkvm -ldl -lssl -lcrypto 
-licui18n -licuuc -licudata
/usr/lib/gcc/x86_64-kfreebsd-gnu/5/../../../x86_64-kfreebsd-gnu/libuv.so: 
undefined reference to `uv__platform_loop_delete'
/usr/lib/gcc/x86_64-kfreebsd-gnu/5/../../../x86_64-kfreebsd-gnu/libuv.so: 
undefined reference to `uv__hrtime'
/usr/lib/gcc/x86_64-kfreebsd-gnu/5/../../../x86_64-kfreebsd-gnu/libuv.so: 
undefined reference to `uv__platform_invalidate_fd'
/usr/lib/gcc/x86_64-kfreebsd-gnu/5/../../../x86_64-kfreebsd-gnu/libuv.so: 
undefined reference to `uv__io_poll'
/usr/lib/gcc/x86_64-kfreebsd-gnu/5/../../../x86_64-kfreebsd-gnu/libuv.so: 
undefined reference to `uv__platform_loop_init'
/usr/lib/gcc/x86_64-kfreebsd-gnu/5/../../../x86_64-kfreebsd-gnu/libuv.so: 
undefined reference to `uv__fs_event_close'
collect2: error: ld returned 1 exit status


I suspect kqueue.c is missing.
Investigating...

Jérémy

--- End Message ---
--- Begin Message ---
Source: libuv1
Source-Version: 1.7.4-2

We believe that the bug you reported is fixed in the latest version of
libuv1, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 799...@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Luca Bruno <lu...@debian.org> (supplier of updated libuv1 package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmas...@ftp-master.debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Format: 1.8
Date: Sat, 19 Sep 2015 20:56:54 +0200
Source: libuv1
Binary: libuv1-dev libuv1 libuv1-dbg
Architecture: source
Version: 1.7.4-2
Distribution: unstable
Urgency: medium
Maintainer: Debian Javascript Maintainers 
<pkg-javascript-devel@lists.alioth.debian.org>
Changed-By: Luca Bruno <lu...@debian.org>
Description:
 libuv1     - asynchronous event notification library - runtime library
 libuv1-dbg - asynchronous event notification library - debugging symbols
 libuv1-dev - asynchronous event notification library - development files
Closes: 799446
Changes:
 libuv1 (1.7.4-2) unstable; urgency=medium
 .
   * Initial porting to kFreeBSD (Closes: #799446)
Checksums-Sha1:
 0de0ba4cd5f78f319e7047c839599d14c744c225 2064 libuv1_1.7.4-2.dsc
 9e9bbb9036f3f6d318d21af7944c85b0b97e3d25 23892 libuv1_1.7.4-2.debian.tar.xz
Checksums-Sha256:
 1d19836c3d6f171e29dd2a3ec09a7bb496480cc4765776b0bbd7c2237c5b2216 2064 
libuv1_1.7.4-2.dsc
 2a35b76352e71e688ff0e2339b2e01347e983358bbcccc6ae9b7a5d9e2d73f60 23892 
libuv1_1.7.4-2.debian.tar.xz
Files:
 04fe9e7579596942316b6c03a974bf82 2064 libs optional libuv1_1.7.4-2.dsc
 ede4edff45cbbe1341cda0ab6d441828 23892 libs optional 
libuv1_1.7.4-2.debian.tar.xz

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iQIcBAEBAgAGBQJV/bBbAAoJEKmDSiJSB45OrWwP/3VLNNzk6nI6YAPcz0aOaaTq
m42YKAxTNnEOkLnR6dh/Cgm3X1O55LaLJ4zulphxe+mHJUD0FctRe3f+7C6RBMOL
dLmikp1dJfo5gH2S8bmVnG4j+aL2vAY7+6DJU4DR4GaRLJc+Z7dIHnSijF9vx354
AxnX5W+XGtPR4ttRf1wDThrzAKKKkan1UOgDEB2bdVTY4pNdxTpcN1BRVRaFJLMw
iFwqoF7qdRolSu54z6KRDlaw3ERyVToZ1ebViJcpEbp/aljKnQw/eHS5Wek8YtXD
vVUN1peYNYQrP32ezskgwMbnp6s4FtU82tnDFhyq35ixEw2X9HNKyeYOjflYce9Q
oIUrAUm3QFvhYlaj45CmtgjfDHgtJc1xP4aJ3t9oPh/tI/iiCqJfTJzHtn/ryWNd
vR08uWUUpUpzODeXdtsuJvXj2iiSjT2KzmRt0e1w3EHSkTnbCx4pKu8q4HJ7YaMr
kGQucVOAEfvfshp5f4BQPWTTf1iFQ8+q1a+G5RTicKqhobJHn+r9zL0BwDEMJa56
/bBuQkJ9+xuZCTHq2oWY7y+xuBZGZUK6dBQbX2kwkn/Bmn+oDJrwjVxBc1+5e3gZ
Bq1OHKvo3m2vwJZIq+Q/G4jk8ospQwm9u7DQCzPbu/LGGbTpbkCewWet0a2MGcxQ
U/AQEFOnDrevfuRCNa4w
=MQVP
-----END PGP SIGNATURE-----

--- End Message ---
_______________________________________________
Pkg-javascript-devel mailing list
Pkg-javascript-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-javascript-devel

Reply via email to