2015-09-21 11:02 GMT+02:00 Chris Lamb <la...@debian.org>:

> Source: node-websocket
> Version: 1.0.19-1
> Severity: serious
> Justification: fails to build from source
> User: reproducible-bui...@lists.alioth.debian.org
> Usertags: ftbfs
> X-Debbugs-Cc: reproducible-bui...@lists.alioth.debian.org
>
> Dear Maintainer,
>
> node-websocket fails to build from source in unstable/amd64:
>
>   [..]
>
>   make[3]: Entering directory '/tmp/buildd/node-websocket-1.0.19/build'
>     CXX(target) Release/obj.target/bufferutil/src/bufferutil.o
>   ../src/bufferutil.cc: In static member function 'static void
>   BufferUtil::Initialize(v8::Handle<v8::Object>)':
>   ../src/bufferutil.cc:27:14: error: 'NanScope' was not declared in this
>   scope
>        NanScope();
>                 ^
>   ../src/bufferutil.cc:28:33: error: 'NanNew' was not declared in this
>   scope
>        Local<FunctionTemplate> t = NanNew<FunctionTemplate>(New);
>                                    ^
>   ../src/bufferutil.cc:28:56: error: expected primary-expression before
>   '>' token
>        Local<FunctionTemplate> t = NanNew<FunctionTemplate>(New);
>                                                           ^
>   ../src/bufferutil.cc:30:52: error: no matching function for call to
>   'NODE_SET_METHOD(v8::Local<v8::FunctionTemplate>&, const char [7],
>   Nan::NAN_METHOD_RETURN_TYPE (&)(Nan::NAN_METHOD_ARGS_TYPE))'
>        NODE_SET_METHOD(t, "unmask", BufferUtil::Unmask);
>                                                       ^
>   [..]
>
> The full build log is attached or can be viewed here:
>
>
> https://reproducible.debian.net/logs/unstable/amd64/node-websocket_1.0.19-1.build1.log.gz
>
>
Thank you,
note that probably all "old" modules are going to be broken, since the
upload of nodejs 4 in unstable.
 We will, of course, proceed to upload updated compatible versions.

Jérémy
_______________________________________________
Pkg-javascript-devel mailing list
Pkg-javascript-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-javascript-devel

Reply via email to