Your message dated Mon, 28 Sep 2015 23:32:43 +0200
with message-id 
<CAJxTCxyEFMUCVrprHEkMv9ijt1e49HjvPOQSNvJt+LV=uvML=w...@mail.gmail.com>
and subject line Re: #763611: nodejs: please remove libuv and http-parser from 
source
has caused the Debian Bug report #763611,
regarding nodejs: please remove libuv and http-parser from source
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
763611: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=763611
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Package: nodejs
Version: 0.10.29~dfsg-1
Severity: normal

Dear Maintainer,

Currently nodejs source package contains the sources to v8, libuv and
http-parser in its deps directory. All these libs are available as
packages within debian (and nodejs already depends on libv8), wouldn't it 
then make sense to use those packages and not ship these with nodejs?

Also, see policy 4.13
https://www.debian.org/doc/debian-policy/ch-source.html#s-embeddedfiles

Cheers, Oli

-- System Information:
Debian Release: jessie/sid
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 3.14-1-amd64 (SMP w/4 CPU cores)
Locale: LANG=is_IS.utf8, LC_CTYPE=is_IS.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages nodejs depends on:
ii  libc-ares2    1.10.0-2
ii  libc6         2.19-4
ii  libgcc1       1:4.9.0-1
ii  libssl1.0.0   1.0.1h-3
ii  libstdc++6    4.9.0-1
ii  libv8-3.14.5  3.14.5.8-8
ii  zlib1g        1:1.2.8.dfsg-1

nodejs recommends no packages.

nodejs suggests no packages.

-- no debconf information

--- End Message ---
--- Begin Message ---
> Package: nodejs
> Version: 0.10.29~dfsg-1
> Severity: normal
> Dear Maintainer,
> Currently nodejs source package contains the sources to v8, libuv and
> http-parser in its deps directory. All these libs are available as
> packages within debian (and nodejs already depends on libv8), wouldn't it
> then make sense to use those packages and not ship these with nodejs?
> Also, see policy 4.13
> https://www.debian.org/doc/debian-policy/ch-source.html#s-embeddedfiles

This reference doesn't say the unused parts should be removed.
It says convenient copies shouldn't be *used* if they are available
as debian packages; and if they're not, they should be packaged.

For the record, nodejs >= 4.0 is now using bundled v8 and c-ares because
upstream maintains adhoc patches of those libs.

Using a debian-packaged version of v8 made updating nodejs very complicated,
so i'm not even sure it was a good idea.
For c-ares, i expect it to come back to the system version, or even better,
to not be part of future nodejs versions (there has been talk about a pure
js
dns module).

Closing because we're already doing as much as we can.

Jérémy

--- End Message ---
_______________________________________________
Pkg-javascript-devel mailing list
Pkg-javascript-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-javascript-devel

Reply via email to