Your message dated Mon, 12 Oct 2015 21:52:40 +0000
with message-id <e1zll1m-0002wi...@franck.debian.org>
and subject line Bug#693944: fixed in less.js 1.6.3~dfsg-1
has caused the Debian Bug report #693944,
regarding node-less: lessc --help empty, no man page, useless documentation
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
693944: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=693944
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Package: node-less
Version: 1.3.1~20121105-1
Severity: important
Tags: patch

Dear Maintainer,

I installed node-less 1.3.1~20121105-1 and attempted to run lessc. I received
the following output:

lessc: no input files


module.js:337
    throw new Error("Cannot find module '" + request + "'");
          ^
Error: Cannot find module '../lib/less/lessc_helper'
    at Function._resolveFilename (module.js:337:11)
    at Function._load (module.js:279:25)
    at Module.require (module.js:359:17)
    at require (module.js:375:17)
    at Object.<anonymous> (/usr/bin/lessc:99:5)
    at Module._compile (module.js:446:26)
    at Object..js (module.js:464:10)
    at Module.load (module.js:353:32)
    at Function._load (module.js:311:12)
    at Array.0 (module.js:484:10)

I believe that this is because lessc is looking for lessc_helper in
"/usr/lib/less/lessc_helper". On my system, it is located at
"/usr/lib/nodejs/less/lessc_helper".



-- System Information:
Debian Release: wheezy/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (1, 'experimental')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 3.5-trunk-amd64 (SMP w/4 CPU cores)
Locale: LANG=en_US.utf8, LC_CTYPE=en_US.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages node-less depends on:
ii  nodejs  0.6.19~dfsg1-5

node-less recommends no packages.

--- End Message ---
--- Begin Message ---
Source: less.js
Source-Version: 1.6.3~dfsg-1

We believe that the bug you reported is fixed in the latest version of
less.js, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 693...@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Jonas Smedegaard <d...@jones.dk> (supplier of updated less.js package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmas...@ftp-master.debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

Format: 1.8
Date: Mon, 12 Oct 2015 23:23:16 +0200
Source: less.js
Binary: libjs-less node-less
Architecture: source all
Version: 1.6.3~dfsg-1
Distribution: unstable
Urgency: medium
Maintainer: Debian Javascript Maintainers 
<pkg-javascript-devel@lists.alioth.debian.org>
Changed-By: Jonas Smedegaard <d...@jones.dk>
Description:
 libjs-less - LESS CSS meta-language - Javascript library
 node-less  - LESS CSS meta-language - compiler and Node module
Closes: 693944 800353
Changes:
 less.js (1.6.3~dfsg-1) unstable; urgency=medium
 .
   [ upstream ]
   * New release(s).
     + Avoids sys.puts.
       Closes: Bug#800353. Thanks to Sebastian Rittau.
 .
   [ Jonas Smedegaard ]
   * Adjust comment about when to drop backport-easing fallback
     build-dependency on yui-compressor.
     Thanks to Alexander E. Patrakov.
   * Update copyright info:
     + Update source URLs.
     + Extend coverage of packaging to include current year.
     + Drop Files sections (and corresponding License section) for files
       no longer shipped upstream since before 1.4.2.
     + Extend coverage for main upstream author.
   * Update source URLs in watch file and CDBS hints.
   * Reimplement build (i.e. mostly concatenation) in rules file:
     Upstream is moving to grunt which is not yet in Debian.
     Build-depend on libyaml-tiny-perl.
   * Install upstream CLI script in library path and symlink to bin path
     (instead of patching paths in script).
   * Bump debhelper compatibility level to 9.
   * Move package VCS to pkg-javascript team.
   * Add patches cherry-picked upstream to succeed testsuite with modern
     Nodejs.
   * Repackage upstream tarball to avoid sourceless binary code,
     potentially sourceless minified code, and convenience code copies.
     Mangle version in watch file (to match default CDBS suffix ~dfsg).
   * Update patch 2001.
   * Build-depend on and recommend node-source-map.
   * Stop build-depend on yui-compressor as fallback: Nodejs needed
     during build so backporting to oldstable is a pain anyway.
   * Strip article from short descriptions.
 .
   [ Christian Amsüss ]
   * Declare compliance with Debian Policy 3.9.6.
   * Build man page using help2man.
     Closes: Bug#693944. Thanks to Martey Dodoo and David Prévot.
   * Update Vcs-* URIs.
Checksums-Sha1:
 ebbdb35490b3d0254eaa93c4e7c001796bd1070b 2086 less.js_1.6.3~dfsg-1.dsc
 b7e7b4a380257b733819551bb8534de2cf4e4c87 245528 less.js_1.6.3~dfsg.orig.tar.gz
 40b967ac66d71540004fbf7de368a38befa83009 10552 
less.js_1.6.3~dfsg-1.debian.tar.xz
 d33451a3f6443eb3351afb2d7b656bb1108a96b8 94714 libjs-less_1.6.3~dfsg-1_all.deb
 d344a96f35c34b2f43754c1d687438dc059d5496 80384 node-less_1.6.3~dfsg-1_all.deb
Checksums-Sha256:
 39085f12307e1c32ca07e228f6b4dc2dc45c1e24c59429cb2efc217d157cabf6 2086 
less.js_1.6.3~dfsg-1.dsc
 e465700e34d25c3bf062b6aefe16dba8d54bb7feb3f8da1623172f369c6fc406 245528 
less.js_1.6.3~dfsg.orig.tar.gz
 6dd792bde906eb93c693483d888406a61f5d1abd7a873c8507d6cc9275312ae2 10552 
less.js_1.6.3~dfsg-1.debian.tar.xz
 f399f82a7e0ff5a0ecf39866944f2f3dfe35eaf1cb0521ab27efe1bd8656efb9 94714 
libjs-less_1.6.3~dfsg-1_all.deb
 1014ac6c13c9725e3d723bb537c04ea73cc62d13aeefb79c03ddf0ab47ab3ce4 80384 
node-less_1.6.3~dfsg-1_all.deb
Files:
 be21441c76b629debe62063825ea3815 2086 web optional less.js_1.6.3~dfsg-1.dsc
 bb2f95a258e732270a83fdf8c2d7f559 245528 web optional 
less.js_1.6.3~dfsg.orig.tar.gz
 9e8fc940fb79382df6fdb86d6f5e4ef5 10552 web optional 
less.js_1.6.3~dfsg-1.debian.tar.xz
 da18ede4b5b5d3322aaac434fa5c66ea 94714 web optional 
libjs-less_1.6.3~dfsg-1_all.deb
 ca0e33290aa6778cf09e5b61797b9b9c 80384 web optional 
node-less_1.6.3~dfsg-1_all.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2

iQIcBAEBCAAGBQJWHCZFAAoJECx8MUbBoAEhhJgP/ix9BF/lCJRnNBPWilswOtHX
80eiuw57oyFPxq8uB6+c+4qUqCzBFJrp3WeGmo9XlZwU1uNqdzTvB4GGEB66ZBzJ
Sp/QgvH3iFwj1iSgToyDw+9P7qWRLwBEkXvr3CmphQ2almvT5KgerY6WkmRVgX1K
vRvNk9S784vF4/OsUsKp7sMDBxSQq5/O3nvNGkrozcw89MtyUcM+MYdJncMlv6v1
KqIQ578FD9U+VAPFBE7YJ5txv9FfRx8mRu5EBulTzoCj9J55PQevmGWrRL1h4hoM
+1Fzz+/isyeMzOvpuAIXFz/QTY4l3bWc0K3TCEAWns5uR+hY0dDIBxOE9YL5S5Ay
aA8KWtzcybr8al0I1qel5q8lqnvEIVe9F5Ep3L5R6pwBZkT7OoMr+qmw1P0iZYZS
mFHSKpJHgQSlzvrI8EjsZzDqh44VeFnF3NMO/G9I4MwK5jJEu0mwCHNjqCDbrQo1
z+RUYRHLzbT+/fBgUGpAigYTWnu/BvNyA+Th3hLWR2MkPJrJrQlAQ4x8h/GvweGy
+U/VYFLEIBHWvdUg1DGwmOvvIH6AkvMOVud7fa+dc40fPKVk/b9CtaJygnq1Qpzd
0JqIrZ/x5cpgS+6EkP+G49wruic3MYCouHXTr4T1ak7poFxpX3NmSy7WN0NCRdBf
/LqOZlArenZI3CbUYmCM
=34lq
-----END PGP SIGNATURE-----

--- End Message ---
_______________________________________________
Pkg-javascript-devel mailing list
Pkg-javascript-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-javascript-devel

Reply via email to