Package: wnpp
Severity: wishlist

* Package name    : node-es6ify
  Version         : 1.6.0
  Upstream Author : Thorsten Lorenz [http://thlorenz.com/]
* URL             : https://thlorenz.github.io/es6ify/
* License         : Expat
  Programming Lang: Javacript
  Description     : browserify v2 transform to compile ES6 to ES5 on the fly

Es6ify uses a browserify v2 transform to compile JavaScript.next (ES6) to
JavaScript.current (ES5) on the fly.

Node.js is an event-based server-side JavaScript engine.

node-isstream is a build dependency of Browserify
(https://bugs.debian.org/780357).

Dependencies:
NPM                                               Debian
es6ify (1.6.0)                                    None
├─ through (~2.2.7)                               node-through2 (1.1.1-1)
├─ traceur (0.0.79)                               None
│  ├─ commander (2.6)                             node-commander
(2.4.0-1)
│  ├─ glob (4.3)                                  node-glob (4.0.5-1)
│  ├─ rsvp (^3.0.13)                              None
│  ├─ semver (2.x)                                node-semver (2.1.0-2)
│  └─ source-map-support (~0.2.8)                 None
│     └─ source-map (0.1.32)                      node-source-map
(0.1.40-1)
└─ xtend (~2.2.0)                                 node-extend (2.0.0-1)

Warnings occured:
 [warning] xtend: extend does the same job
 [warning] through: through2 is better maintained, see node-jsonstream for a
patch

_______________________________________________
Pkg-javascript-devel mailing list
Pkg-javascript-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-javascript-devel

Reply via email to