Source: modernizr
Version: 2.6.2+ds1-1
Severity: minor

Dear Maintainer,

I have notices that your package libjs-modernizr does not build
reproducibly from the modernizr source package because of
nondeterministic input order given by shell globbing.
See https://reproducible-builds.org/docs/stable-inputs/ for more
information.

I have attached a patch that makes the build reproducible for me.

Many thanks,
Sascha 
diff --git a/debian/rules b/debian/rules
index bf23418..e49a481 100755
--- a/debian/rules
+++ b/debian/rules
@@ -14,7 +14,7 @@ DEBVER := $(UPVER)+ds1
 	dh $@
 
 override_dh_auto_build:
-	cat feature-detects/*.js > feature-detects.js
+	find feature-detects -name '*.js' | LC_ALL=C sort | xargs cat > feature-detects.js
 	uglifyjs -o modernizr.min.js modernizr.js
 
 	# Drop copyright from minified version since it would get
_______________________________________________
Pkg-javascript-devel mailing list
Pkg-javascript-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-javascript-devel

Reply via email to