On 04/08/2016 02:20 PM, Jérémy Lal wrote:
> 2016-04-08 14:04 GMT+02:00 Sebastiaan Couwenberg:
>> The test target fails because it requires node-pre-gyp, as do the
>> bin/mapnik-*.js executables. We'll need to patch those to not require
>> node-pre-gyp too.
>>
>> Do you have any suggestions for that?
> 
> Yes, i have: i'm packaging node-pre-gyp and rc modules, it seems pkg-tar
> could stay a recommandation.
> It will be way simpler than spending the time patching node-mapnik.

Thanks!

I've patched the mapnik-*.js executables to not require node-pre-gyp,
that just leaves lib/mapnik.js which uses it to find mapnik_settings.js.

Since its path differs between the build environment and after
installation, I'm not sure if we can make it support both without
node-pre-gyp.

I think I'll leave the node-mapnik packaging as it is for now, add have
another look when node-pre-gyp is available or if it becomes clear we
can work around it.

Kind Regards,

Bas

-- 
 GPG Key ID: 4096R/6750F10AE88D4AF1
Fingerprint: 8182 DE41 7056 408D 6146  50D1 6750 F10A E88D 4AF1

_______________________________________________
Pkg-javascript-devel mailing list
Pkg-javascript-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-javascript-devel

Reply via email to