Your message dated Mon, 11 Apr 2016 23:39:34 +0000
with message-id <e1aplqc-0008ih...@franck.debian.org>
and subject line Bug#792065: fixed in node-mocha 1.20.1-2
has caused the Debian Bug report #792065,
regarding FTBFS: Use CoffeeScript.register() or require [..] to require 
.coffee.md files
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
792065: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=792065
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Source: node-mocha
Version: 1.20.1-1
Severity: serious
Tags: sid stretch
Justification: fails to build from source
User: reproducible-bui...@lists.alioth.debian.org
Usertags: ftbfs

Dear Maintainer,

The package fails to build:

make test-all
make[2]: Entering directory '/tmp/buildd/node-mocha-1.20.1'
[loads of stuff that doesn't render properly]
done

/usr/lib/coffee-script/lib/coffee-script/coffee-script.js:213
          throw new Error("Use CoffeeScript.register() or require the coffee-s
                ^
Error: Use CoffeeScript.register() or require the coffee-script/register module 
to require .coffee.md files.
  at Object.base.(anonymous function) [as .coffee] 
(/usr/lib/coffee-script/lib/coffee-script/coffee-script.js:213:17)
  at Module.load (module.js:356:32)
  at Function.Module._load (module.js:312:12)
  at Module.require (module.js:364:17)
  at require (module.js:380:17)
  at /tmp/buildd/node-mocha-1.20.1/lib/mocha.js:172:27
  at Array.forEach (native)
  at Mocha.loadFiles (/tmp/buildd/node-mocha-1.20.1/lib/mocha.js:169:14)
  at Mocha.run (/tmp/buildd/node-mocha-1.20.1/lib/mocha.js:356:31)
  at Object.<anonymous> (/tmp/buildd/node-mocha-1.20.1/bin/_mocha:366:16)
  at Module._compile (module.js:456:26)
  at Object.Module._extensions..js (module.js:474:10)
  at Module.load (module.js:356:32)
  at Function.Module._load (module.js:312:12)
  at Function.Module.runMain (module.js:497:10)
  at startup (node.js:119:16)
  at node.js:906:3

Makefile:48: recipe for target 'test-compilers' failed
make[2]: *** [test-compilers] Error 8
make[2]: Leaving directory '/tmp/buildd/node-mocha-1.20.1'

Full build log:
https://reproducible.debian.net/rb-pkg/unstable/amd64/node-mocha.html


-- System Information:
Debian Release: stretch/sid
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: amd64 (x86_64)

Kernel: Linux 3.19.0-22-generic (SMP w/8 CPU cores)
Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

--- End Message ---
--- Begin Message ---
Source: node-mocha
Source-Version: 1.20.1-2

We believe that the bug you reported is fixed in the latest version of
node-mocha, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 792...@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Jérémy Lal <kapo...@melix.org> (supplier of updated node-mocha package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmas...@ftp-master.debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

Format: 1.8
Date: Tue, 12 Apr 2016 00:43:45 +0200
Source: node-mocha
Binary: mocha libjs-mocha
Architecture: source all
Version: 1.20.1-2
Distribution: unstable
Urgency: medium
Maintainer: Debian Javascript Maintainers 
<pkg-javascript-devel@lists.alioth.debian.org>
Changed-By: Jérémy Lal <kapo...@melix.org>
Description:
 libjs-mocha - simple, flexible, fun test framework - JavaScript library
 mocha      - simple, flexible, fun test framework - Node.js module
Closes: 785302 792065
Changes:
 node-mocha (1.20.1-2) unstable; urgency=medium
 .
   * Patch to remove customFds deprecation warning
   * Patch to remove CoffeeScript.register deprecation warning,
     Closes: #792065.
   * Symlink mocha.js, mocha.css from libjs-mocha to known places
     for node-mocha to be able to find them. Closes: #785302.
Checksums-Sha1:
 226fbd51e3d9c8a5d48b68deed57196f77703540 2141 node-mocha_1.20.1-2.dsc
 de2de60cf6220d06274a2d33476c8ed586e920c0 4972 node-mocha_1.20.1-2.debian.tar.xz
 4e84bd21a6bec3fab59b2a46ebf14cae49758da6 54804 libjs-mocha_1.20.1-2_all.deb
 f4a732d568ddf6738a57a0d183c7aaa7a7bba230 57410 mocha_1.20.1-2_all.deb
Checksums-Sha256:
 5b764d6c0d88208f14ed5570433086e4a113e3fa279ca3fba69a7788543b0afb 2141 
node-mocha_1.20.1-2.dsc
 8008c229364968b8a6fefd4e018f3a8d001e52dc7389b6fded78b4b7bfd90425 4972 
node-mocha_1.20.1-2.debian.tar.xz
 30279e69c68991ef2400744904055e076309cd757c300ff32c4a5ebbd05a78d4 54804 
libjs-mocha_1.20.1-2_all.deb
 2df14ef5045b336c0ed539759587609eb4d5cbec4aa56769da8835378b0182a3 57410 
mocha_1.20.1-2_all.deb
Files:
 2514c3119da4d5735232d0f56ca16a33 2141 web extra node-mocha_1.20.1-2.dsc
 3670b119dc80097bcec9d3d0eee6046c 4972 web extra 
node-mocha_1.20.1-2.debian.tar.xz
 e4dd7573d3e4a7c7f2112dfdf456e07f 54804 web extra libjs-mocha_1.20.1-2_all.deb
 44f4b1d27af260d4cb0e32f5d993679d 57410 web extra mocha_1.20.1-2_all.deb

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iQIcBAEBCgAGBQJXDC2HAAoJEGYRwF7dOfN09msP/jiwa2PN4sEMSFOhexskigq6
oc2EsU1MjKyaZnRQErPCYD9KgUJmyuSgormpUwCFNC/LgxkNK+1mlCp9xLD4NyMm
oht79twIJuJ6YhWO9id1JkF1BhX0hPV2bsUGuL0bDalDNy7bxKjOxJoR3J8rvgRm
eXNWBaPdYfTtg9k6nyx7r8tSXCY08a4KHE+NyyK4A9m3HRaXQ6J29JozGyxcnGwr
mRvpMTbjlBwA/LWuajQaV5BKDDmcSoEYRW7hT5XW+THWh4zco0UfrJNsJhvTgbP5
sg2wAREU7QL8TzP7ljmUIwwi8P1gYVSQjTLHuuDU4j3RxdDs7TYTkoZBU3c2owPM
L0h+1LCOzOr2AkVkItwaeA7Io7W0WuUns9QbikcFvL0pnSFIs5zaiJgOlmmIgcZz
47gmEsW/X00RqzoL4hf3QrQTFwOezc9w4AYAULA0vbvg8Jjzx3zHghJozfVCah5Q
9VvXWmqj4zVmWeg5IMqVFHpCTTDUtlo4NM9k+ib922bHDUcp90KoWEDGE+34SJJf
lsh3/5ie3sfBQNxEB1LSGoVv59GIRXCOWe6ExikOLRRSVvN3XKenqnmYyLLKmsc9
Y6muhKoLB8vPz6X+OyeVGxBcCO9+Mzks4RmGoA9befalhdtyFZOJtnFCmkMFIboG
32s/NvzNbirbKggTRrPM
=KuY6
-----END PGP SIGNATURE-----

--- End Message ---
_______________________________________________
Pkg-javascript-devel mailing list
Pkg-javascript-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-javascript-devel

Reply via email to