Source: node-lodash
Version: 2.4.1+dfsg-3
Severity: serious
Justification: fails to build from source
User: reproducible-bui...@lists.alioth.debian.org
Usertags: ftbfs
X-Debbugs-Cc: reproducible-bui...@lists.alioth.debian.org

Dear Maintainer,

node-lodash fails to build from source in unstable/amd64 when 
/bin/sh is set to bash:

  […]

     debian/rules override_dh_auto_build
  make[1]: Entering directory 
'/home/lamby/temp/cdt.20161022151027.jj3SRN2eOz.db.node-lodash/node-lodash-2.4.1+dfsg'
  dh_auto_build
  if [ ! -d debian/build ]; \
  then mkdir debian/build; \
  fi; \
  do \
        cp lodash.js debian/build/; \
        uglifyjs  -o debian/build/$(basename lodash .js).min.js lodash.js; \
  done
  /bin/sh: -c: line 3: syntax error near unexpected token `do'
  /bin/sh: -c: line 3: `do \'
  debian/rules:16: recipe for target 'override_dh_auto_build' failed

  […]

The full build log is attached.


Regards,

-- 
      ,''`.
     : :'  :     Chris Lamb
     `. `'`      la...@debian.org / chris-lamb.co.uk
       `-

Attachment: node-lodash.2.4.1+dfsg-3.unstable.amd64.log.txt.gz
Description: Binary data

-- 
Pkg-javascript-devel mailing list
Pkg-javascript-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-javascript-devel

Reply via email to