Your message dated Mon, 31 Oct 2016 22:34:43 +0000 (GMT)
with message-id <20161031223444.330608e3...@orbiter.shiftout.net>
and subject line pthread-barrier.h not actually needed
has caused the Debian Bug report #842743,
regarding libuv1-dev: Please install pthread-barrier.h in the -dev package
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
842743: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=842743
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Package: libuv1-dev
Version: 1.9.1-1
Severity: important

Hi,

Trying to build software with libuv1-dev on kFreeBSD results in errors similar
to the following:

> cmake --build .
> [  1%] Building C object CMakeFiles/neat.dir/neat_addr.c.o
> In file included from /usr/include/uv.h:62:0,
>                  from /home/irl/neat/neat_internal.h:5,
>                  from /home/irl/neat/neat_addr.c:7:
> /usr/include/uv-unix.h:61:30: fatal error: pthread-barrier.h: No such file or 
> directory
>  # include "pthread-barrier.h"
>                               ^
> compilation terminated.

This is because uv-unix.h tries to include this file but it was never included
in the package. On Linux the fallback to this mechanism isn't required and so
this file does not get included.

> http://sources.debian.net/src/libuv1/1.9.1-3/include/uv-unix.h/#L61

Thanks,
Iain.

--- End Message ---
--- Begin Message ---
Hi,

Ignore this, fixed with -D_GNU_SOURCE

Thanks,
Iain.

--- End Message ---
-- 
Pkg-javascript-devel mailing list
Pkg-javascript-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-javascript-devel

Reply via email to