Your message dated Tue, 1 Nov 2016 16:43:03 +0100
with message-id <>
and subject line Re: node-es6-promise: FTBFS: compile-modules shows help
has caused the Debian Bug report #841614,
regarding node-es6-promise: FTBFS: compile-modules shows help
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact

Debian Bug Tracking System
Contact with problems
--- Begin Message ---
Source: node-es6-promise
Version: 3.2.2+ds-1
Severity: serious
Tags: stretch sid
Usertags: qa-ftbfs-20161021 qa-ftbfs
Justification: FTBFS on amd64


During a rebuild of all packages in sid, your package failed to build on

Relevant part (hopefully):
> make[1]: Entering directory '/<<BUILDDIR>>/node-es6-promise-3.2.2+ds'
> mkdir dist
> compile-modules convert -f bundle -o dist/es6-promise.js 
> lib/es6-promise.umd.js
> compile-modules [--help] [--version] <command> [<args>]
> Commands
>   convert  Converts modules from `import`/`export` to an ES5 equivalent.
>   help     Display help for a given command.
> debian/rules:10: recipe for target 'override_dh_auto_build' failed
> make[1]: *** [override_dh_auto_build] Error 1

If the failure looks somehow time/timezone related:
Note that this rebuild was performed without the 'tzdata' package
installed in the chroot. tzdata used be (transitively) part of
build-essential, but it no longer is. If this package requires it to
build, it should be added to build-depends. For the release team's
opinion on this, see

If the failure looks LSB-related:
similarly to tzdata, lsb-base is not installed in the build chroot.

The full build log is available from:

A list of current common problems and possible solutions is available at . You're welcome to contribute!

About the archive rebuild: The rebuild was done on EC2 VM instances from
Amazon Web Services, using a clean, minimal and up-to-date chroot. Every
failed build was retried once to eliminate random failures.

--- End Message ---
--- Begin Message ---

On 31/10/16 at 18:43 +0100, Julien Puydt wrote:
> Hi,
> On 31/10/2016 08:01, Lucas Nussbaum wrote:
> > On 29/10/16 at 11:14 +0200, Julien Puydt wrote:
> > > Hi,
> > > 
> > > I tried to "pbuilder create" a new base.tgz, but it still had tzdata and
> > > lsb-base, so I had to "pbuilder login --save-after-login" and remove them 
> > > by
> > > hand using "dpkg --purge" (then "apt-get autoremove" that did nothing). I
> > > still had no problem building node-es6-promise.
> > > 
> > > How can I get the clean, minimal and up-to-date chroot you mention in your
> > > report?
> > 
> > Hi Julien,
> > 
> > You can install debfoster in the chroot, and then run
> > debfoster -o UseRecommends=no -o MaxPriority=required
> > 
> > to clean up the chroot from non-essential packages.
> I made several tests with your debfoster line :
> (*) if I let dpkg-dev go, pbuilder can't even try to compile packages
> because it's missing dpkg-architecture
> (*) if I let gcc go, dpkg-architecture can't determine the system type ;
> (*) if I let aptitude go, pbuilder can't install the build deps ;
> (*) if I let build-essential go, pbuilder will install the build deps, but
> dpkg-buildpackage will fail because of unmet build dependencies (on
> build-essential: native !)
> So I kept apt, aptitude and build-essential : no problem building
> node-es6-promise with pbuilder.
> Since I really wanted to fix that bug, I thought I could get a smaller
> chroot by doing things by hand -- after all I have less needs than pbuilder
> : using debfoster I kept only apt, then installed nano so I could edit the
> sources.list (enable the deb-src line) and apt-get update, then installed
> the build-dep for node-es6-promise, apt-get source node-es6-promise, then
> dpkg-buildpackage -b -us -uc... no problem!
> I don't manage to reproduce the failure, and I don't know what I could try
> next. Do you have more ideas?

I tried to rebuild this package in an updated chroot, and it seems that
the failure has been fixed after one build-dependency was updated.

Here is an updated log:

I looked at some of the build-dependencies that changed, but couldn't
determine which one caused the change.

I'm closing the bug, sorry for the lost effort.

Just for the record, in the chroot, build-essential needs to be kept
(it's required to be there by policy).


--- End Message ---
Pkg-javascript-devel mailing list

Reply via email to