On Saturday 12 November 2016 04:31 PM, Pirate Praveen wrote:
> Hi,
> 
> Using globally installed grunt is not supported upstream (see
> https://github.com/gruntjs/grunt-cli/issues/10). With
> https://github.com/gruntjs/grunt-cli/pull/55 patch, I was able to ignore
> the error but it fails to read package.json now
> 
> $ grunt
> Loading "Gruntfile.js" tasks...ERROR
>>> Error: Unable to read "package.json" file (Error code: MODULE_NOT_FOUND).
> Warning: Task "default" not found. Use --force to continue.
> 
> Aborted due to warnings.
> 
> Can someone help fix this? (you'll have to build grunt from alioth as it
> is still in NEW).

After a whole day of troubleshooting, I found the issue was with
encoding conversion. The patch remove-encoding-conversion.patch in
alioth fixes this error. I'd like someone to review it before I upload it.


Attachment: signature.asc
Description: OpenPGP digital signature

-- 
Pkg-javascript-devel mailing list
Pkg-javascript-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-javascript-devel

Reply via email to