Package: npm
Version: 1.4.21+ds-2
Severity: normal

Current npm requires a version of node-glob at least >= 4.2.0 because of
the glob.hasMagic() function. However, the debian package metadata
currently claims that node-glob >= 3.1.21 is sufficient.

The upshot of that is that it fails by

npm ERR! TypeError: glob.hasMagic is not a function
npm ERR!     at rimraf (/usr/lib/nodejs/rimraf/rimraf.js:61:36)
npm ERR!     at gentlyRm (/usr/share/npm/lib/utils/gently-rm.js:29:12)
npm ERR!     at rmGunz (/usr/share/npm/lib/utils/tar.js:171:5)

-- System Information:
Debian Release: stretch/sid
  APT prefers testing
  APT policy: (990, 'testing'), (500, 'unstable')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 4.8.0-1-amd64 (SMP w/4 CPU cores)
Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages npm depends on:
ii  node-abbrev               1.0.9-1
ii  node-ansi                 0.3.0-2
ii  node-ansi-color-table     1.0.0-1
ii  node-archy                0.0.2-1
ii  node-block-stream         0.0.9-1
ii  node-fstream              1.0.10-1
ii  node-fstream-ignore       0.0.6-2
ii  node-github-url-from-git  1.4.0-1
ii  node-glob                 7.1.1-1
ii  node-graceful-fs          4.1.11-1
ii  node-gyp                  3.4.0-1
ii  node-inherits             2.0.3-1
ii  node-ini                  1.1.0-1
ii  node-lockfile             0.4.1-1
ii  node-lru-cache            2.3.1-1
ii  node-minimatch            3.0.3-1
ii  node-mkdirp               0.5.0-1
ii  node-nopt                 3.0.6-3
ii  node-npmlog               0.0.4-1
ii  node-once                 1.4.0-2
ii  node-osenv                0.1.0-1
ii  node-read                 1.0.5-1
ii  node-read-package-json    1.2.4-1
ii  node-request              2.26.1-1
ii  node-retry                0.6.0-1
ii  node-rimraf               2.5.4-2
ii  node-semver               5.3.0-1
ii  node-sha                  1.2.3-1
ii  node-slide                1.1.4-1
ii  node-tar                  2.2.1-1
ii  node-underscore           1.8.3~dfsg-1
ii  node-which                1.0.5-2
ii  nodejs                    4.6.1~dfsg-1

npm recommends no packages.

npm suggests no packages.

-- no debconf information

Paul "LeoNerd" Evans      |  |

Pkg-javascript-devel mailing list

Reply via email to