[adding debian-ruby and #847353]

On വ്യാഴം 08 ഡിസംബര്‍ 2016 10:34 രാവിലെ, Pirate Praveen wrote:
> I think you are only checking for jquery-ui.js and not all the other files 
> like jquery-ui/widgets/datepicker.js
> 
> I did not see any error in gitlab when using the embedded copy of jquery-ui 
> in ruby-jquery-ui-rails (removed .links and installed app directory). So it 
> has to be a bug in the build system.

I just found the root cause, ruby-jquery-ui-rails adds dependency
mapping at the top in addition to embedding the corresponding jquery-ui
files. There is a rake task to generate these files if we symlink
pkg-javascript/jqueryui directory to ruby-jquery-ui-rails/jquery-ui. I
think if we create node-jquery-ui package and add it as a build
dependency of ruby-jquery-ui-rails and symlink /usr/lib/nodejs/jquery-ui
to ruby-jquery-ui-rails/jquery-ui this will solve the problem.

ruby-jquery-ui-rails$ diff -u
app/assets/javascripts/jquery-ui/widgets/draggable.js
/usr/share/javascript/jquery-ui/ui/widgets/draggable.js
--- app/assets/javascripts/jquery-ui/widgets/draggable.js       2016-12-07
11:27:13.193475539 +0530
+++ /usr/share/javascript/jquery-ui/ui/widgets/draggable.js     2016-09-14
22:01:37.000000000 +0530
@@ -1,12 +1,3 @@
-//= require jquery-ui/widgets/mouse
-//= require jquery-ui/data
-//= require jquery-ui/plugin
-//= require jquery-ui/safe-active-element
-//= require jquery-ui/safe-blur
-//= require jquery-ui/scroll-parent
-//= require jquery-ui/version
-//= require jquery-ui/widget
-
 /*!
  * jQuery UI Draggable 1.12.1
  * http://jqueryui.com



Attachment: signature.asc
Description: OpenPGP digital signature

-- 
Pkg-javascript-devel mailing list
Pkg-javascript-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-javascript-devel

Reply via email to