Package: npm
Version: 1.4.21+ds-2
Followup-For: Bug #837929

I got hit by this bug today. I'm a noob on Javascript and only wanted to
install npm to explore some gnome shell extension functionality, which
requried me to try out some JS modules.

Upon installing npm, and then trying installing a module, doesn't give a
good experience on Debian.


rrs@learner:/tmp$ npm install inotify
-
> inotify@1.4.1 install /tmp/node_modules/inotify
> node-gyp rebuild

/bin/sh: 1: node: not found
gyp: Call to 'node -e "require('nan')"' returned exit status 127 while in 
binding.gyp. while trying to load binding.gyp
gyp ERR! configure error 
gyp ERR! stack Error: `gyp` failed with exit code: 1
gyp ERR! stack     at ChildProcess.onCpExit 
(/usr/share/node-gyp/lib/configure.js:304:16)
gyp ERR! stack     at emitTwo (events.js:87:13)
gyp ERR! stack     at ChildProcess.emit (events.js:172:7)
gyp ERR! stack     at Process.ChildProcess._handle.onexit 
(internal/child_process.js:200:12)
gyp ERR! System Linux 4.8.15+
gyp ERR! command "/usr/bin/nodejs" "/usr/bin/node-gyp" "rebuild"
gyp ERR! cwd /tmp/node_modules/inotify
gyp ERR! node -v v4.6.1
gyp ERR! node-gyp -v v3.4.0
gyp ERR! not ok 
npm WARN This failure might be due to the use of legacy binary "node"
npm WARN For further explanations, please read
/usr/share/doc/nodejs/README.Debian
 
npm ERR! inotify@1.4.1 install: `node-gyp rebuild`
npm ERR! Exit status 1
npm ERR! 
npm ERR! Failed at the inotify@1.4.1 install script.
npm ERR! This is most likely a problem with the inotify package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR!     node-gyp rebuild
npm ERR! You can get their info via:
npm ERR!     npm owner ls inotify
npm ERR! There is likely additional logging output above.

npm ERR! System Linux 4.8.15+
npm ERR! command "/usr/bin/nodejs" "/usr/bin/npm" "install" "inotify"
npm ERR! cwd /tmp
npm ERR! node -v v4.6.1
npm ERR! npm -v 1.4.21
npm ERR! code ELIFECYCLE
npm ERR! 
npm ERR! Additional logging details can be found in:
npm ERR!     /tmp/npm-debug.log
npm ERR! not ok code 0
2016-12-23 / 18:20:49 ♒♒♒  ☹  => 1  

-- System Information:
Debian Release: stretch/sid
  APT prefers testing-debug
  APT policy: (990, 'testing-debug'), (990, 'testing'), (500, 
'unstable-debug'), (500, 'unstable'), (101, 'experimental')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 4.8.15+ (SMP w/4 CPU cores)
Locale: LANG=en_IN.utf8, LC_CTYPE=en_IN.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash
Init: systemd (via /run/systemd/system)

Versions of packages npm depends on:
ii  node-abbrev               1.0.9-1
ii  node-ansi                 0.3.0-2
ii  node-ansi-color-table     1.0.0-1
ii  node-archy                0.0.2-1
ii  node-block-stream         0.0.9-1
ii  node-fstream              1.0.10-1
ii  node-fstream-ignore       0.0.6-2
ii  node-github-url-from-git  1.4.0-1
ii  node-glob                 7.1.1-1
ii  node-graceful-fs          4.1.11-1
ii  node-gyp                  3.4.0-1
ii  node-inherits             2.0.3-1
ii  node-ini                  1.1.0-1
ii  node-lockfile             0.4.1-1
ii  node-lru-cache            4.0.2-1
ii  node-minimatch            3.0.3-1
ii  node-mkdirp               0.5.0-1
ii  node-nopt                 3.0.6-3
ii  node-npmlog               0.0.4-1
ii  node-once                 1.4.0-2
ii  node-osenv                0.1.0-1
ii  node-read                 1.0.5-1
ii  node-read-package-json    1.2.4-1
ii  node-request              2.26.1-1
ii  node-retry                0.6.0-1
ii  node-rimraf               2.5.4-2
ii  node-semver               5.3.0-1
ii  node-sha                  1.2.3-1
ii  node-slide                1.1.4-1
ii  node-tar                  2.2.1-1
ii  node-underscore           1.8.3~dfsg-1
ii  node-which                1.2.11-1
ii  nodejs                    4.6.1~dfsg-1

npm recommends no packages.

npm suggests no packages.

-- no debconf information

-- 
Pkg-javascript-devel mailing list
Pkg-javascript-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-javascript-devel

Reply via email to