Hi all,

On 29/11/16 12:20, Antonio Terceiro wrote:
> On Mon, Nov 28, 2016 at 10:44:08PM +0530, Pirate Praveen wrote:
>> On 2016, നവംബർ 28 10:27:15 PM IST, Paolo Greppi <paolo.gre...@libpf.com> 
>> wrote:
>>> Hi this is opinionated but very useful. I have a couple of newbie
>>> questions.
>>>
>>> Did you try these scripts on Debian stable as host ?
>> No, I have not tried.
> Neither did I, but I will be happy to merge patches if anything does not
> work.

I run Jessie on my laptop, and thought I would give pkg-ruby-extras a
go. I ran into problems running the setup script due to a lack of space
under /root (too many chroots & containers!). This is my fault and a
problem I had been meaning to fix for a while.

So after fixing that, the next problem is that you run into #843137 with
sbuild (there have been a lot of changes in unstable/stretch with apt &
gpg). You have to install sbuild from jessie-backports to fix that.

Then the build command works fine up until the debci bit:
Run the test suite now? [Y/n]y
adt-run [16:44:30]: version 3.6jessie1
Error: container adt-sid-amd64 is not defined
<VirtSubproc>: failure: ['sudo', 'lxc-clone', '--new',
'adt-virt-lxc-tbsmsn', '--orig', 'adt-sid-amd64'] failed (exit status 1)
adt-run [16:44:30]: ERROR: testbed failed: cannot send to testbed:
['BrokenPipeError: [Errno 32] Broken pipe\n']

WARNING: Test suite failed! Please verify before uploading

Now edit /home/ross/.chdist/unstable/etc/apt/sources.list
Run chdist apt-get unstable update
And enjoy.

I suppose I will have to create the adt-sid-amd64 manually, and then run
into the same gpg/apt issue. But it is Christmas Eve now, and that will
have to wait.

All the best!

Ross
-- 
Pkg-javascript-devel mailing list
Pkg-javascript-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-javascript-devel

Reply via email to