Source: node-browserify-lite
Version: 0.3.0-1
Severity: serious

When I rebuild node-browserify-lite under pbuilder, the resulting contents are:

drwxr-xr-x root/root         0 2015-07-07 14:10 ./
drwxr-xr-x root/root         0 2015-07-07 14:10 ./usr/
drwxr-xr-x root/root         0 2015-07-07 14:10 ./usr/bin/
drwxr-xr-x root/root         0 2015-07-07 14:10 ./usr/lib/
drwxr-xr-x root/root         0 2015-07-07 14:10 ./usr/lib/nodejs/
drwxr-xr-x root/root         0 2015-07-07 14:10
./usr/lib/nodejs/browserify-lite/
-rw-r--r-- root/root      1049 2015-07-07 14:10
./usr/lib/nodejs/browserify-lite/cli.js
-rw-r--r-- root/root      9731 2015-07-07 13:45
./usr/lib/nodejs/browserify-lite/index.js
-rw-r--r-- root/root       565 2015-07-07 13:45
./usr/lib/nodejs/browserify-lite/package.json
drwxr-xr-x root/root         0 2015-07-07 14:10 ./usr/share/
drwxr-xr-x root/root         0 2015-07-07 14:10 ./usr/share/doc/
drwxr-xr-x root/root         0 2015-07-07 14:10
./usr/share/doc/node-browserify-lite/
-rw-r--r-- root/root       846 2015-07-07 13:45
./usr/share/doc/node-browserify-lite/README.md
-rw-r--r-- root/root       367 2015-07-07 14:10
./usr/share/doc/node-browserify-lite/changelog.Debian.gz
-rw-r--r-- root/root      1450 2015-07-07 14:10
./usr/share/doc/node-browserify-lite/copyright
drwxr-xr-x root/root         0 2015-07-07 14:10 ./usr/share/lintian/
drwxr-xr-x root/root         0 2015-07-07 14:10 ./usr/share/lintian/overrides/
-rw-r--r-- root/root        93 2015-07-07 14:10
./usr/share/lintian/overrides/node-browserify-lite
drwxr-xr-x root/root         0 2015-07-07 14:10 ./usr/share/man/
drwxr-xr-x root/root         0 2015-07-07 14:10 ./usr/share/man/man1/
-rw-r--r-- root/root       335 2015-07-07 14:10
./usr/share/man/man1/browserify-lite.1.gz
lrwxrwxrwx root/root         0 2015-07-07 14:10
./usr/bin/browserify-lite -> ../lib/nodejs/browserify-lite/cli.js

Note that /usr/lib/nodejs/browserify-lite/cli.js is not executable.
This causes errors building other packages if I install the rebuilt
node-browserify-lite package; for example, from should.js:

 debian/rules build
dh build
  dh_testdir
  dh_update_autotools_config
  dh_auto_configure
  debian/rules override_dh_auto_build
make[1]: Entering directory '/build/should.js-8.4.0~dfsg'
dh_auto_build
browserify-lite . --standalone should --outfile should.js
make[1]: execvp: browserify-lite: Permission denied
debian/rules:11: recipe for target 'override_dh_auto_build' failed
make[1]: *** [override_dh_auto_build] Error 127
make[1]: Leaving directory '/build/should.js-8.4.0~dfsg'
debian/rules:8: recipe for target 'build' failed
make: *** [build] Error 2
dpkg-buildpackage: error: debian/rules build gave error exit status 2
-- 
Daniel Schepler

-- 
Pkg-javascript-devel mailing list
Pkg-javascript-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-javascript-devel

Reply via email to