Hi all,

I was just looking and saw that python3-matplotlib shows the same symptoms i.e -

[$] adequate python3-matplotlib
python3-matplotlib: broken-symlink
/usr/lib/python3/dist-packages/matplotlib/backends/web_backend/jquery/css/themes/base/jquery-ui.min.css
-> 
../../../../../../../../../../share/javascript/jquery-ui/css/smoothness/jquery-ui.min.css

To make sure that the broken symlink is not something due to me/system
state at my end, I decided to purge the package and again install it
to see whether I get the same broken symlink or not.

Fortunately for me, there were not many dependencies therein -

[$] sudo aptitude purge python-matplotlib python3-matplotlib
python-matplotlib-data python3-cycler python-cycler -y
[12:21:19]
The following packages will be REMOVED:
  python-cycler{pu} python-matplotlib{p} python-matplotlib-data{pu}
python3-cycler{pu} python3-matplotlib{p}
0 packages upgraded, 0 newly installed, 5 to remove and 91 not upgraded.
....

lots of aptitude verbose output, what I/We are looking for comes right
at the end -

adequate found packaging bugs
-----------------------------

python3-matplotlib: broken-symlink
/usr/lib/python3/dist-packages/matplotlib/backends/web_backend/jquery/css/themes/base/jquery-ui.min.css
->
../../../../../../../../../../share/javascript/jquery-ui/css/smoothness/jquery-ui.min.css
python-matplotlib: broken-symlink
/usr/lib/python2.7/dist-packages/matplotlib/backends/web_backend/jquery/css/themes/base/jquery-ui.min.css
->
../../../../../../../../../../share/javascript/jquery-ui/css/smoothness/jquery-ui.min.css

So the issue is not an installation bug but rather a packaging bug .

Who's responsible, I'll let you two gentleman figure it out.

-- 
          Regards,
          Shirish Agarwal  शिरीष अग्रवाल
  My quotes in this email licensed under CC 3.0
http://creativecommons.org/licenses/by-nc/3.0/
http://flossexperiences.wordpress.com
EB80 462B 08E1 A0DE A73A  2C2F 9F3D C7A4 E1C4 D2D8

-- 
Pkg-javascript-devel mailing list
Pkg-javascript-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-javascript-devel

Reply via email to