Hi,

readdirp 2.1.0 uses set-immediate-shim. We already have setimmediate, so
I tried patching readdirp to use setimmediate, but chokidar tests fail
with incompatible type when using setimmediate.

I see two solutions
1. Package set-immediate-shim
2. See if only tests are the problem, then fix tests
3. Adapt readdirp to use setimmediate directly

I prefer to do 1st as it does not require much javascript coding. If
someone helps me with the other options (and reduce one extra package to
maintain), that would be nice.

Attachment: signature.asc
Description: OpenPGP digital signature

-- 
Pkg-javascript-devel mailing list
Pkg-javascript-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-javascript-devel

Reply via email to