Package: coffeescript
Version: 1.12.7~dfsg-1
Severity: serious

Most (all?) packages build-depending on coffeescript
FTBFS with 1.12.7~dfsg-1, example:

https://tests.reproducible-builds.org/debian/rb-pkg/unstable/amd64/camo.html

...
   debian/rules override_dh_auto_build
make[1]: Entering directory '/build/1st/camo-2.3.0+dfsg'
rake --trace build
** Invoke build (first_time)
** Invoke server.js (first_time)
** Invoke server.coffee (first_time, not_needed)
** Execute server.js
coffee -c -o . server.coffee
module.js:471
    throw err;
    ^

Error: Cannot find module '../../package.json'
    at Function.Module._resolveFilename (module.js:469:15)
    at Function.Module._load (module.js:417:25)
    at Module.require (module.js:497:17)
    at require (internal/module.js:20:19)
    at Object.<anonymous> 
(/usr/lib/coffee-script/lib/coffee-script/coffee-script.js:20:17)
    at Object.<anonymous> 
(/usr/lib/coffee-script/lib/coffee-script/coffee-script.js:426:4)
    at Module._compile (module.js:570:32)
    at Object.Module._extensions..js (module.js:579:10)
    at Module.load (module.js:487:32)
    at tryModuleLoad (module.js:446:12)
rake aborted!
Command failed with status (1): [coffee -c -o . server.coffee...]
/usr/lib/ruby/vendor_ruby/rake/file_utils.rb:66:in `block in 
create_shell_runner'
/usr/lib/ruby/vendor_ruby/rake/file_utils.rb:56:in `sh'
/build/1st/camo-2.3.0+dfsg/Rakefile:2:in `block in <top (required)>'
/usr/lib/ruby/vendor_ruby/rake/task.rb:250:in `block in execute'
/usr/lib/ruby/vendor_ruby/rake/task.rb:250:in `each'
/usr/lib/ruby/vendor_ruby/rake/task.rb:250:in `execute'
/usr/lib/ruby/vendor_ruby/rake/task.rb:194:in `block in invoke_with_call_chain'
/usr/lib/ruby/2.3.0/monitor.rb:214:in `mon_synchronize'
/usr/lib/ruby/vendor_ruby/rake/task.rb:187:in `invoke_with_call_chain'
/usr/lib/ruby/vendor_ruby/rake/task.rb:216:in `block in invoke_prerequisites'
/usr/lib/ruby/vendor_ruby/rake/task.rb:214:in `each'
/usr/lib/ruby/vendor_ruby/rake/task.rb:214:in `invoke_prerequisites'
/usr/lib/ruby/vendor_ruby/rake/task.rb:193:in `block in invoke_with_call_chain'
/usr/lib/ruby/2.3.0/monitor.rb:214:in `mon_synchronize'
/usr/lib/ruby/vendor_ruby/rake/task.rb:187:in `invoke_with_call_chain'
/usr/lib/ruby/vendor_ruby/rake/task.rb:180:in `invoke'
/usr/lib/ruby/vendor_ruby/rake/application.rb:152:in `invoke_task'
/usr/lib/ruby/vendor_ruby/rake/application.rb:108:in `block (2 levels) in 
top_level'
/usr/lib/ruby/vendor_ruby/rake/application.rb:108:in `each'
/usr/lib/ruby/vendor_ruby/rake/application.rb:108:in `block in top_level'
/usr/lib/ruby/vendor_ruby/rake/application.rb:117:in `run_with_threads'
/usr/lib/ruby/vendor_ruby/rake/application.rb:102:in `top_level'
/usr/lib/ruby/vendor_ruby/rake/application.rb:80:in `block in run'
/usr/lib/ruby/vendor_ruby/rake/application.rb:178:in 
`standard_exception_handling'
/usr/lib/ruby/vendor_ruby/rake/application.rb:77:in `run'
/usr/bin/rake:27:in `<main>'
Tasks: TOP => build => server.js
debian/rules:30: recipe for target 'override_dh_auto_build' failed
make[1]: *** [override_dh_auto_build] Error 1

-- 
Pkg-javascript-devel mailing list
Pkg-javascript-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-javascript-devel

Reply via email to