I have just updated the repo:
https://anonscm.debian.org/cgit/pkg-javascript/node-yarnpkg.git
with upstream's latest release (1.2.1).

W.r.t. the previous time I looked (version 1.0.2 of 2017-09-13) the 
dependencies have not changed much:
- 2 new dependencies (strip-ansi and puka)
- node-camelcase goes from 3.0.0 to 4.0.0
- node-chalk goes from 1.1.1 to 2.1.0

I also updated the task page 
https://wiki.debian.org/Javascript/Nodejs/Tasks/yarn using the commands:

grep -v eslint-plugin-yarn-internal package.json > package1.json
./js-task-wiki-edit/js_task_edit.py -f package1.json

Let's set aside for the moment the staggering figure of 142 packages to update.

Assuming some dependencies can be skipped:
- jest, flow, flow-bin, commitizen and cz-conventional-changelog: these seem 
tools required for the upstream development workflow
- cmd-shim: should be required only on windows
- leven: node-fast-levenshtein is in debian and it should be easy to patch yarn 
to use that instead (or ask ustream, since fast-levenshtein seems more popular 
than leven)
and not counting the babel / eslint stuff and the indirect dependencies for 
direct dependencies we already have in the archive, it seems we need 15 new 
packages.

Before I file ITPs for these:
- asap
- chownr
- dnscache
- gulp-if
- gulp-watch 
- gunzip-maybe
- is-ci
- is-webpack-bundle
- mock-stdin
- node-emoji
- prettier
- puka
- tar-fs
- v8-compile-cache
- yn
do you have any comments on them ?

Paolo

-- 
Pkg-javascript-devel mailing list
Pkg-javascript-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-javascript-devel

Reply via email to