On 11/14/2017 04:53 PM, John Paul Adrian Glaubitz wrote:
> Use the Architecture field to list the architectures, separate by spaces
> which are supported for a particular package. The attached patch should
> do the right thing.

I have just been hinted at on IRC that kfreebsd-i386 and kfreebsd-amd64
are missing in the first patch I sent. I have therefore added them
as well in an updated patch attached to this mail.

Thanks,
Adrian

-- 
 .''`.  John Paul Adrian Glaubitz
: :' :  Debian Developer - glaub...@debian.org
`. `'   Freie Universitaet Berlin - glaub...@physik.fu-berlin.de
  `-    GPG: 62FF 8A75 84E0 2956 9546  0006 7426 3B37 F5B5 F913
>From 4103322d2172d68f25980292932de19b6d6b8079 Mon Sep 17 00:00:00 2001
From: John Paul Adrian Glaubitz <glaub...@physik.fu-berlin.de>
Date: Tue, 14 Nov 2017 16:51:15 +0100
Subject: [PATCH] Use architecture whitelist for binary packages

---
 debian/control.in | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/debian/control.in b/debian/control.in
index f62de8b2..2aef6ed5 100644
--- a/debian/control.in
+++ b/debian/control.in
@@ -15,7 +15,7 @@ Vcs-Git: https://anonscm.debian.org/git/collab-maint/nodejs.git
 Package: nodejs-dev
 Section: devel
 Priority: extra
-Architecture: !armel
+Architecture: amd64 arm64 armhf i386 kfreebsd-i386 kfreebsd-amd64 mips mips64el mipsel ppc64 ppc64el s390x
 Depends: ${cdbs:Depends},
  ${misc:Depends},
  nodejs (= ${binary:Version})
@@ -30,7 +30,7 @@ Description: evented I/O for V8 javascript (development files)
  This package is needed to build plugins.
 
 Package: nodejs
-Architecture: !armel
+Architecture: amd64 arm64 armhf i386 kfreebsd-i386 kfreebsd-amd64 mips mips64el mipsel ppc64 ppc64el s390x
 Depends: ${shlibs:Depends},
  ${misc:Depends}
 Provides: ${cdbs:Provides}
-- 
2.11.0

-- 
Pkg-javascript-devel mailing list
Pkg-javascript-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-javascript-devel

Reply via email to