Hi, I have prepared the update to node-wrap-ansi 3.0.1

With this update, I could enable the tests.
To work around the issue with the test environment mentioned here:
https://lists.alioth.debian.org/pipermail/pkg-javascript-devel/2016-November/015662.html
I had to employ the "trick" used in node-chalk tests:
https://github.com/chalk/chalk/blob/master/test/enabled.js#L4

With this "trick" in place, all tests pass except the last one
("supports unicode surrogate pairs")
Pending closer investigation on that, I just disabled it.

It has node-cliui as reverse dependency, which builds fine apart for a known 
problem (https://bugs.debian.org/880904).

Please someone allow me DM upload access for this package or sponsor the upload:
https://anonscm.debian.org/cgit/pkg-javascript/node-wrap-ansi.git

Paolo

-- 
Pkg-javascript-devel mailing list
Pkg-javascript-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-javascript-devel

Reply via email to