On Fri, 14 Jul 2017 15:28:40 +0200 Julien Puydt
<julien.pu...@laposte.net> wrote:> I can't help but notice that Debian
has 1.20.1 while upstream is now up
> to 3.4.2.
> 
> Could we get a less ancient version?
> 
> Since the package is in the Debian JavaScript Maintainers repository, I
> might lend a help if you want to.

I tried to update it to 4.0.1 and getting this error (using webpack
instead of browserify). Wondering why webpack is not able to find 'fs'.
Should we add any extra path to resolve modules included with nodejs?

==> [Browser :: build]
mkdir -p .
"webpack" ./browser-entry mocha.js \
--config debian/webpack.config.js \
--target=web \
--output-library=mocha \
--output-library-target=umd
Hash: 47caafb0f8710340edca
Version: webpack 3.5.6
Time: 1082ms
   Asset    Size  Chunks                    Chunk Names
mocha.js  458 kB       0  [emitted]  [big]  main
   [0] /usr/lib/nodejs/process/browser.js 5.42 kB {0} [built]
   [1] ./lib/utils.js 16.2 kB {0} [built]
   [3] (webpack)/buildin/global.js 488 bytes {0} [built]
   [9] ./lib/test.js 1.05 kB {0} [built]
  [14] ./lib/runnable.js 8.64 kB {0} [built]
  [31] ./lib/hook.js 743 bytes {0} [built]
  [32] ./browser-entry.js 4.27 kB {0} [built]
  [33] /usr/lib/nodejs/browser-stdout/index.js 649 bytes {0} [built]
  [34] /usr/lib/nodejs/stream-browserify/index.js 3.63 kB {0} [built]
  [49] ./lib/mocha.js 12.7 kB {0} [built]
  [50] ./lib/reporters/index.js 946 bytes {0} [built]
  [77] ./lib/interfaces/index.js 155 bytes {0} [built]
  [82] ./lib/context.js 1.83 kB {0} [built]
  [83] ./lib/runner.js 22.9 kB {0} [built]
  [84] ./lib/browser/growl.js 82 bytes {0} [built]
    + 70 hidden modules

WARNING in ./lib/mocha.js
153:20-37 Critical dependency: the request of a dependency is an expression

WARNING in ./lib/mocha.js
158:24-70 Critical dependency: the request of a dependency is an expression

WARNING in ./lib/mocha.js
193:17-30 Critical dependency: the request of a dependency is an expression

WARNING in ./lib/mocha.js
231:26-39 Critical dependency: the request of a dependency is an expression

ERROR in /usr/lib/nodejs/mkdirp/index.js
Module not found: Error: Can't resolve 'fs' in '/usr/lib/nodejs/mkdirp'
 @ /usr/lib/nodejs/mkdirp/index.js 2:9-22
 @ ./lib/reporters/xunit.js
 @ ./lib/reporters/index.js
 @ ./lib/mocha.js
 @ ./browser-entry.js
Makefile:21: recipe for target 'mocha.js' failed

Attachment: signature.asc
Description: OpenPGP digital signature

-- 
Pkg-javascript-devel mailing list
Pkg-javascript-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-javascript-devel

Reply via email to