Your message dated Fri, 29 Dec 2017 15:08:14 +0000
with message-id <e1euwgc-0007bk...@fasolo.debian.org>
and subject line Bug#884041: fixed in node-braces 2.0.2-2
has caused the Debian Bug report #884041,
regarding node-braces FTBFS: test failures
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
884041: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=884041
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Source: node-braces
Version: 2.0.2-1
Severity: serious
Tags: buster sid

Some recent change in unstable makes node-braces FTBFS:

https://tests.reproducible-builds.org/debian/history/node-braces.html
https://tests.reproducible-builds.org/debian/rb-pkg/unstable/amd64/node-braces.html

...
  5 failing

  1) bash.expanded should compile: {214748364..2147483649}:
     AssertionError: {214748364..2147483649}
      at match (/build/1st/node-braces-2.0.2/test/bash.expanded.js:9:10)
      at Context.<anonymous> 
(/build/1st/node-braces-2.0.2/test/bash.expanded.js:408:7)
      at callFn (/usr/lib/nodejs/mocha/lib/runnable.js:223:21)
      at Test.Runnable.run (/usr/lib/nodejs/mocha/lib/runnable.js:216:7)
      at Runner.runTest (/usr/lib/nodejs/mocha/lib/runner.js:373:10)
      at /usr/lib/nodejs/mocha/lib/runner.js:451:12
      at next (/usr/lib/nodejs/mocha/lib/runner.js:298:14)
      at /usr/lib/nodejs/mocha/lib/runner.js:308:7
      at next (/usr/lib/nodejs/mocha/lib/runner.js:246:23)
      at Immediate.<anonymous> (/usr/lib/nodejs/mocha/lib/runner.js:275:5)
      at runCallback (timers.js:672:20)
      at tryOnImmediate (timers.js:645:5)
      at processImmediate [as _immediateCallback] (timers.js:617:5)

  2) bash.expanded should compile: {214748364..2147483649}:
     AssertionError: {214748364..2147483649}
      at match (/build/1st/node-braces-2.0.2/test/bash.optimized.js:9:10)
      at Context.<anonymous> 
(/build/1st/node-braces-2.0.2/test/bash.optimized.js:406:7)
      at callFn (/usr/lib/nodejs/mocha/lib/runnable.js:223:21)
      at Test.Runnable.run (/usr/lib/nodejs/mocha/lib/runnable.js:216:7)
      at Runner.runTest (/usr/lib/nodejs/mocha/lib/runner.js:373:10)
      at /usr/lib/nodejs/mocha/lib/runner.js:451:12
      at next (/usr/lib/nodejs/mocha/lib/runner.js:298:14)
      at /usr/lib/nodejs/mocha/lib/runner.js:308:7
      at next (/usr/lib/nodejs/mocha/lib/runner.js:246:23)
      at Immediate.<anonymous> (/usr/lib/nodejs/mocha/lib/runner.js:275:5)
      at runCallback (timers.js:672:20)
      at tryOnImmediate (timers.js:645:5)
      at processImmediate [as _immediateCallback] (timers.js:617:5)

  3) bash.expanded should compile: {214748364..2147483649}:
     AssertionError: {214748364..2147483649}
      at match (/build/1st/node-braces-2.0.2/test/bash.optimized.js:9:10)
      at Context.<anonymous> 
(/build/1st/node-braces-2.0.2/test/bash.optimized.js:406:7)
      at callFn (/usr/lib/nodejs/mocha/lib/runnable.js:223:21)
      at Test.Runnable.run (/usr/lib/nodejs/mocha/lib/runnable.js:216:7)
      at Runner.runTest (/usr/lib/nodejs/mocha/lib/runner.js:373:10)
      at /usr/lib/nodejs/mocha/lib/runner.js:451:12
      at next (/usr/lib/nodejs/mocha/lib/runner.js:298:14)
      at /usr/lib/nodejs/mocha/lib/runner.js:308:7
      at next (/usr/lib/nodejs/mocha/lib/runner.js:246:23)
      at Immediate.<anonymous> (/usr/lib/nodejs/mocha/lib/runner.js:275:5)
      at runCallback (timers.js:672:20)
      at tryOnImmediate (timers.js:645:5)
      at processImmediate [as _immediateCallback] (timers.js:617:5)

  4) expanded ranges large numbers should expand large numbers:
     AssertionError: [ 
'(21474836[4-9]|2147483[7-9][0-9]|214748[4-9][0-9]{2}|214749[0-9]{3}|2147[5-9][0-9]{4}|214[89][0-9]{5}|21[5-9][0-9]{6}|2[2-9][
 deepEqual [ 
'(21474836[4-9]|2147483[7-9][0-9]|214748[4-9][0-9]{2}|214749[0-9]{3}|2147[5-9][0-9]{4}|214[8-9][0-9]{5}|21[5-9][0-9]{6}|2[2-9]
      at match (/build/1st/node-braces-2.0.2/test/expanded.ranges.js:8:10)
      at Context.<anonymous> 
(/build/1st/node-braces-2.0.2/test/expanded.ranges.js:128:7)
      at callFn (/usr/lib/nodejs/mocha/lib/runnable.js:223:21)
      at Test.Runnable.run (/usr/lib/nodejs/mocha/lib/runnable.js:216:7)
      at Runner.runTest (/usr/lib/nodejs/mocha/lib/runner.js:373:10)
      at /usr/lib/nodejs/mocha/lib/runner.js:451:12
      at next (/usr/lib/nodejs/mocha/lib/runner.js:298:14)
      at /usr/lib/nodejs/mocha/lib/runner.js:308:7
      at next (/usr/lib/nodejs/mocha/lib/runner.js:246:23)
      at Immediate.<anonymous> (/usr/lib/nodejs/mocha/lib/runner.js:275:5)
      at runCallback (timers.js:672:20)
      at tryOnImmediate (timers.js:645:5)
      at processImmediate [as _immediateCallback] (timers.js:617:5)

  5) optimized ranges large numbers should expand large numbers:
     AssertionError: [ 
'(21474836[4-9]|2147483[7-9][0-9]|214748[4-9][0-9]{2}|214749[0-9]{3}|2147[5-9][0-9]{4}|214[89][0-9]{5}|21[5-9][0-9]{6}|2[2-9][
 deepEqual [ 
'(21474836[4-9]|2147483[7-9][0-9]|214748[4-9][0-9]{2}|214749[0-9]{3}|2147[5-9][0-9]{4}|214[8-9][0-9]{5}|21[5-9][0-9]{6}|2[2-9]
      at match (/build/1st/node-braces-2.0.2/test/optimized.js:15:10)
      at Context.<anonymous> 
(/build/1st/node-braces-2.0.2/test/optimized.js:269:9)
      at callFn (/usr/lib/nodejs/mocha/lib/runnable.js:223:21)
      at Test.Runnable.run (/usr/lib/nodejs/mocha/lib/runnable.js:216:7)
      at Runner.runTest (/usr/lib/nodejs/mocha/lib/runner.js:373:10)
      at /usr/lib/nodejs/mocha/lib/runner.js:451:12
      at next (/usr/lib/nodejs/mocha/lib/runner.js:298:14)
      at /usr/lib/nodejs/mocha/lib/runner.js:308:7
      at next (/usr/lib/nodejs/mocha/lib/runner.js:246:23)
      at Immediate.<anonymous> (/usr/lib/nodejs/mocha/lib/runner.js:275:5)
      at runCallback (timers.js:672:20)
      at tryOnImmediate (timers.js:645:5)
      at processImmediate [as _immediateCallback] (timers.js:617:5)



debian/rules:13: recipe for target 'override_dh_auto_test' failed
make[1]: *** [override_dh_auto_test] Error 5

--- End Message ---
--- Begin Message ---
Source: node-braces
Source-Version: 2.0.2-2

We believe that the bug you reported is fixed in the latest version of
node-braces, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 884...@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Jérémy Lal <kapo...@melix.org> (supplier of updated node-braces package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmas...@ftp-master.debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

Format: 1.8
Date: Fri, 29 Dec 2017 15:33:23 +0100
Source: node-braces
Binary: node-braces
Architecture: source
Version: 2.0.2-2
Distribution: unstable
Urgency: medium
Maintainer: Debian Javascript Maintainers 
<pkg-javascript-devel@lists.alioth.debian.org>
Changed-By: Jérémy Lal <kapo...@melix.org>
Description:
 node-braces - Fast, comprehensive, bash-like brace expansion implemented in JS
Closes: 884041
Changes:
 node-braces (2.0.2-2) unstable; urgency=medium
 .
   * Team upload
   * Fix tests using upstream version (Closes: #884041)
   * Standards-Version 4.1.2
   * Section: javascript
Checksums-Sha1:
 a0b8259fb4ac8e8311d751480f84d1b9a216c2ce 2368 node-braces_2.0.2-2.dsc
 688f7d361181c467fc50061d325897ea3f4df3d2 8728 node-braces_2.0.2-2.debian.tar.xz
 199c2fd320d9cd827d68398fceb179e60a9257d2 10135 
node-braces_2.0.2-2_source.buildinfo
Checksums-Sha256:
 70408d6dc9128effa62443f2bf71b7a8331ad4ce7ae0356cb0ba3afcf732eadb 2368 
node-braces_2.0.2-2.dsc
 2e303d36b08081434ec81508556a91e11d63c2f957f3d1f5f9e96ed6ce85b1fa 8728 
node-braces_2.0.2-2.debian.tar.xz
 37fda902609cbe624030b1d298a5ffc760d52ccbe822f83690ab8f602bc34367 10135 
node-braces_2.0.2-2_source.buildinfo
Files:
 9ec38a192f6abdfe5943b086a3dbf565 2368 javascript optional 
node-braces_2.0.2-2.dsc
 0efe48a1346de30f4800ca12dc521bf4 8728 javascript optional 
node-braces_2.0.2-2.debian.tar.xz
 f72298ed419cf207603f06bc1d5f01be 10135 javascript optional 
node-braces_2.0.2-2_source.buildinfo

-----BEGIN PGP SIGNATURE-----

iQJGBAEBCgAwFiEEA8Tnq7iA9SQwbkgVZhHAXt0583QFAlpGUrgSHGthcG91ZXJA
bWVsaXgub3JnAAoJEGYRwF7dOfN0gYUP+gPD3APJzMlyk2TlJCkA6w26bS+ydgoC
Tqa46TwJu+TETNq7M8PltA38Ukws6z4GHb2oaXHsx1ZYdUx+IeqnfcLk6MknZTM2
b5Tu8Rosw6SMJy794rXaNfx/wAl+DjUYpig+C1THeV7dASpU8SyJfoSEBje1CsUI
diadptyQwyPTIi1L9kiJgA7jtiD50MkF6PAiLWfkWTP7oxUG482r//V00C99G82k
ebSjuqVqgSXJol7LV/E1q1F6u4Gng2y2L7qD3FYqDM6/ks6cEzLtaE0+iXUE9Dx2
8W7x86Fqc3+bgLYwUrVj3YFuZQupfBqaoUTJMCmTYDts8YLd++I87qvXItzweG8v
eSvd2q9m2Ttxac2t/icK/gbK8S7WObYS606J/eGQaKtgfQi/Wl6rCGc2uX97Uzdp
MwIGI6qFbjUAJuCjoeM4WqcOPdSsz6qIskZwlD2/GhdjP3WQolY0l0gpSQYD9WP1
fW2FKkYCSA5N/m6zmAyGUxOs/QA/dNj+ohMZdk+prZw/73+lqIoI8oUPbK/QnMeD
9XSuCeOyfRkX6wDmYvMGjSSCOX6T6QG5YiNWtr8o7/fgJ5/XbWWqBMwUXc7znOOh
g6NZWe5MoQ8TWVA3XoTHgWsxsOPStuBjfdhmLOZAHsp7XDEN1ZnWHQmlCdN0mg43
mpl3/LobNwK/
=9XGP
-----END PGP SIGNATURE-----

--- End Message ---
-- 
Pkg-javascript-devel mailing list
Pkg-javascript-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-javascript-devel

Reply via email to