Your message dated Fri, 29 Dec 2017 20:50:51 +0000
with message-id <e1ev1cb-0009d4...@fasolo.debian.org>
and subject line Bug#883553: fixed in node-es6-promise 4.1.1+ds-1
has caused the Debian Bug report #883553,
regarding update to newer upstream release
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
883553: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=883553
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Package: node-es6-promise
version: 3.2.2+ds-1
severity: wishlist

Please update to 4.1.1 release. I have tried to update it in babel
branch (using babel), but tests of node-yargs (in git) fails.

mocha --require ./test/before.js --timeout=8000 --check-leaks
/<<PKGBUILDDIR>>/test/completion.js:7
require('es6-promise').polyfill()
                       ^

TypeError: require(...).polyfill is not a function
    at Object.<anonymous> (/<<PKGBUILDDIR>>/test/completion.js:7:24)
    at Module._compile (module.js:570:32)
    at Object.Module._extensions..js (module.js:579:10)
    at Module.load (module.js:487:32)
    at tryModuleLoad (module.js:446:12)
    at Function.Module._load (module.js:438:3)
    at Module.require (module.js:497:17)
    at require (internal/module.js:20:19)
    at /usr/lib/nodejs/mocha/lib/mocha.js:172:27
    at Array.forEach (native)
    at Mocha.loadFiles (/usr/lib/nodejs/mocha/lib/mocha.js:169:14)
    at Mocha.run (/usr/lib/nodejs/mocha/lib/mocha.js:356:31)
    at Object.<anonymous> (/usr/lib/nodejs/mocha/bin/_mocha:366:16)
    at Module._compile (module.js:570:32)
    at Object.Module._extensions..js (module.js:579:10)
    at Module.load (module.js:487:32)
    at tryModuleLoad (module.js:446:12)
    at Function.Module._load (module.js:438:3)
    at Module.runMain (module.js:604:10)
    at run (bootstrap_node.js:383:7)
    at startup (bootstrap_node.js:149:9)
    at bootstrap_node.js:496:3

Attachment: signature.asc
Description: OpenPGP digital signature


--- End Message ---
--- Begin Message ---
Source: node-es6-promise
Source-Version: 4.1.1+ds-1

We believe that the bug you reported is fixed in the latest version of
node-es6-promise, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is
attached.

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 883...@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
pp.
Sruthi Chandran <s...@disroot.org> (supplier of updated node-es6-promise 
package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmas...@ftp-master.debian.org)


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

Format: 1.8
Date: Sat, 30 Dec 2017 00:53:00 +0530
Source: node-es6-promise
Binary: node-es6-promise libjs-es6-promise
Architecture: source
Version: 4.1.1+ds-1
Distribution: unstable
Urgency: medium
Maintainer: Debian Javascript Maintainers 
<pkg-javascript-devel@lists.alioth.debian.org>
Changed-By: Sruthi Chandran <s...@disroot.org>
Description:
 libjs-es6-promise - Lightweight async code library for JavaScript
 node-es6-promise - Lightweight async code library for JavaScript (Node.js 
module)
Closes: 883553
Changes:
 node-es6-promise (4.1.1+ds-1) unstable; urgency=medium
 .
   * Team upload
   * Fix webpack and babel configurations (Thanks to Paolo Greppi)
 .
   [ Pirate Praveen ]
   * New upstream release (Closes: #883553)
   * Switch to babel for transpiling
Checksums-Sha1:
 aa2f726155084df78584baadbfea8cfd09098746 2283 node-es6-promise_4.1.1+ds-1.dsc
 2b70903fc6e4659488bf270fc8ef650bb0c6f771 69819 
node-es6-promise_4.1.1+ds.orig.tar.gz
 0f1ae23357edb1fbfcb022a9c4a2d1760836e895 2864 
node-es6-promise_4.1.1+ds-1.debian.tar.xz
 bdffea0e4b9bc01b58a79c10baac96ebc07d0ee2 15982 
node-es6-promise_4.1.1+ds-1_source.buildinfo
Checksums-Sha256:
 aa1fc8a8d8ca183fc31acda2585ad05829f06c864fae12edcf4dd3567c4276ad 2283 
node-es6-promise_4.1.1+ds-1.dsc
 2036b3b7370b7d90c9f812cfa4f8c48ba2bfb6906e59f5d2f6c1465d371cdb76 69819 
node-es6-promise_4.1.1+ds.orig.tar.gz
 30439df53e31c6e55243c432c4338c90348f4591be9c5ece19c5b1b713f2ddf6 2864 
node-es6-promise_4.1.1+ds-1.debian.tar.xz
 4a59aea738f327296ac7c441eb5911b1ecdab55d15e9cfb67c0e85542be962d5 15982 
node-es6-promise_4.1.1+ds-1_source.buildinfo
Files:
 637e282149634d02b9b6e9e328bf8335 2283 javascript optional 
node-es6-promise_4.1.1+ds-1.dsc
 37c3fc16bf5f8ff20bad4d9b6605a0b4 69819 javascript optional 
node-es6-promise_4.1.1+ds.orig.tar.gz
 331308c2645e0eb0298dff24c04f0224 2864 javascript optional 
node-es6-promise_4.1.1+ds-1.debian.tar.xz
 6283bbc585f639a37b5b00152a02e2c6 15982 javascript optional 
node-es6-promise_4.1.1+ds-1_source.buildinfo

-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEKnl0ri/BUtd4Z9pKzh+cZ0USwioFAlpGooAACgkQzh+cZ0US
wiqPXA//SWQh0sNGHY6gOPlWpglku8bsSgK9MYzlpfJtxEtMLhNTBb4kS/DsxPbm
DWZd9Sp223iOOIXswbf/b3AIXnzjo+Ddefdv+RBpMLrrZFKEH+Mt8495vG0nnsoo
p/0XjKnYp4ZrHy8QRS/fFIUz7oyzd8kcNUKejidf6mQbIhob625A5Y8jwSvrTX6W
eCXNsgFdPjNn6LcC05zPkcAdt9dJXk4PhnC0ne1YkPn21OinvXIAmiSew3yeIm9T
SROs9ieh3AUx+DrqCHF4rtG+C6HSC9qalx2ATaSeUc9s5b1Lhfs7u5OgahtNXS9X
TXVL4SnXzGe4RkZ3a1eMeXUSxS3/pwr0FeDkbUlS9BhC76i8Wp3NRzjVHEC1mI0I
YPyeJ94lS1bIb4+ChxE3VqJWvaCKtsrpl3eOW8J69FPrJIrYxot3Q3MRgJltYm5a
NVFrtmZ1X5fmJmjCHOdpbB2njS1OF8iQ8fIUatVDHMAH2JrlqCWdoX0J7hgF7rb+
Oz62+qdaI2QMhqom+x5MJvMP+NOCy0tiQfCsWWrFhLQHSfnr9KKBgKkltNrGL69z
smLPW8IGFWUilTwM81BLyOdve+c4uP4bs+Xdk+DBy6gnKRzKRuPXOlCL2eas046w
dJ8n5ZDVDD/KFl1LqmzmGVwF14yb8clHTd4ccudey7l3vjieskA=
=JB+1
-----END PGP SIGNATURE-----

--- End Message ---
-- 
Pkg-javascript-devel mailing list
Pkg-javascript-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-javascript-devel

Reply via email to