On ഞായര്‍ 07 ജനുവരി 2018 08:41 വൈകു, Paolo Greppi wrote:
> Il 07/01/2018 15:59, Pirate Praveen ha scritto:
>> ...
>> ERROR in ./bin/src/help.md
>> Module parse failed:
>> /home/pravi/forge/debian/git/pkg-javascript/node-rollup/bin/src/help.md
>> Unexpected token (1:7)
>> You may need an appropriate loader to handle this file type.
>> | rollup version __VERSION__
>> | =====================================
>> |
>>  @ ./bin/src/index.js 2:0-29
> 
> it looks like you need a loader for md files (markdown)
> 
> this one comes up:
> https://github.com/peerigon/markdown-loader
> 
> or just skip files of type markdown altogether:
> https://github.com/cherrry/ignore-loader

I used raw loader and build was successful

https://anonscm.debian.org/cgit/pkg-javascript/node-rollup.git/commit/?h=webpack&id=b3677f65b392d2f82d17f1927c10db4a12905563

It is coming back to babelHelpers missing error. May be I should not be
using external-helpers plugin in the first place or I need to find a way
to include external-helpers.js

Note: I also need to make it a real executable with shebang as well.

node /usr/bin/rollup
/usr/bin/rollup:7955
                                throw _iteratorError2;
                                ^

ReferenceError: babelHelpers is not defined
    at Object.assembleStyles [as exports] (/usr/bin/rollup:7924:4)
    at __webpack_require__ (/usr/bin/rollup:26:26)
    at Object.__webpack_exports__.a (/usr/bin/rollup:127:18)
    at __webpack_require__ (/usr/bin/rollup:20:30)
    at Object.<anonymous> (/usr/bin/rollup:73:64)
    at __webpack_require__ (/usr/bin/rollup:20:30)
    at Object.<anonymous> (/usr/bin/rollup:7564:70)
    at __webpack_require__ (/usr/bin/rollup:20:30)
    at Object.module.exports.opts (/usr/bin/rollup:7196:72)
    at __webpack_require__ (/usr/bin/rollup:20:30)

Attachment: signature.asc
Description: OpenPGP digital signature

-- 
Pkg-javascript-devel mailing list
Pkg-javascript-devel@lists.alioth.debian.org
http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-javascript-devel

Reply via email to