Hi,

I have an issue building 0.1.5 rc2 with Debian unstable:

I gather it can't find some of the XRR symbols ;-(

Mark

g++ -shared -nostdlib
/usr/lib/gcc/powerpc-linux-gnu/4.2.3/../../../../lib/crti.o
/usr/lib/gcc/powerpc-linux-gnu/4.2.3/crtbeginS.o  .libs/listimageitems.o
.libs/plugin_slideshow.o .libs/slideshow.o .libs/slideshowconfig.o
.libs/slideshowgl.o .libs/slideshowloader.o .libs/toolbar.o
.libs/imageloadthread.o .libs/kbeffect.o .libs/screenproperties.o
.libs/slideshowkb.o .libs/slideshowconfigbase.o  -Wl,--rpath
-Wl,/home/mark/src/kde-extras/build-area/kipi-plugins-0.1.5~rc2/obj-powerpc-linux-gnu/kipi-plugins/common/libkipiplugins/.libs
-L/usr/share/qt3/lib
/home/mark/src/kde-extras/build-area/kipi-plugins-0.1.5~rc2/obj-powerpc-linux-gnu/kipi-plugins/common/libkipiplugins/.libs/libkipiplugins.so
/usr/lib/libgpod.so /usr/lib/libgobject-2.0.so /usr/lib/libglib-2.0.so
/usr/lib/libkdefx.so -lGL /usr/lib/libkipi.so /usr/lib/libkdcraw.so
/usr/lib/libkdeui.so /usr/lib/libkdecore.so /usr/lib/libkio.so 
/usr/lib/libqt-mt.so -lpng -lz -lXext -lX11 -lSM -lICE
 -lpthread -L/usr/lib/gcc/powerpc-linux-gnu/4.2.3
 -L/usr/lib/gcc/powerpc-linux-gnu/4.2.3/../../../../lib -L/lib/../lib
 -L/usr/lib/../lib -L/usr/lib/gcc/powerpc-linux-gnu/4.2.3/../../..
 -lstdc++ -lm -lc -lgcc_s /usr/lib/gcc/powerpc-linux-gnu/4.2.3/crtsavres.o
 /usr/lib/gcc/powerpc-linux-gnu/4.2.3/crtendS.o
 /usr/lib/gcc/powerpc-linux-gnu/4.2.3/../../../../lib/crtn.o 
 -Wl,--no-undefined -Wl,--allow-shlib-undefined -Wl,-soname
 -Wl,kipiplugin_slideshow.so -o 
.libs/kipiplugin_slideshow.so.libs/screenproperties.o: In function
`KIPISlideShowPlugin::ScreenProperties::suggestFrameRate()':/home/mark/src/kde-extras/build-area/kipi-plugins-0.1.5~rc2/./kipi-plugins/slideshow/screenproperties.cpp:50:
undefined reference to 
`XRRQueryExtension'/home/mark/src/kde-extras/build-area/kipi-plugins-0.1.5~rc2/./kipi-plugins/slideshow/screenproperties.cpp:59:
undefined reference to 
`XRRGetScreenInfo'/home/mark/src/kde-extras/build-area/kipi-plugins-0.1.5~rc2/./kipi-plugins/slideshow/screenproperties.cpp:61:
undefined reference to 
`XRRConfigCurrentRate'/home/mark/src/kde-extras/build-area/kipi-plugins-0.1.5~rc2/./kipi-plugins/slideshow/screenproperties.cpp:62:
undefined reference to `XRRFreeScreenConfigInfo'collect2: ld returned 1 exit 
status
make[4]: *** [kipiplugin_slideshow.la] Error 1
make[4]: Leaving directory
`/home/mark/src/kde-extras/build-area/kipi-plugins-0.1.5~rc2/obj-powerpc-linux-gnu/kipi-plugins/slideshow'

-- System Information:
Debian Release: lenny/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (1, 'experimental')
Architecture: powerpc (ppc)

Kernel: Linux 2.6.24-1-powerpc
Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages kipi-plugins depends on:
ii  kdelibs4c2a             4:3.5.8.dfsg.1-7 core libraries and binaries
for alii  libc6                   2.7-8            GNU C Library: Shared 
libraries
ii  libgcc1                 1:4.3-20080219-1 GCC support library
ii  libgl1-mesa-glx [libgl1 7.0.2-4          A free implementation of the
OpenGhi  libglib2.0-0            2.14.6-1         The GLib library of C routines
ii  libgphoto2-2            2.4.0-8          gphoto2 digital camera library
ii  libgphoto2-port0        2.4.0-8          gphoto2 digital camera port
librarii  libgpod3                0.6.0-3          a library to read and write
songshi  libimlib2               1.4.0-1          powerful image loading and
renderiii  libjpeg62               6b-14            The Independent JPEG Group's
JPEGii  libkcal2b               4:3.5.8-1        KDE calendaring library
ii  libkdcraw2              0.1.3-1          Raw picture decoding C++
library (ii  libkexiv2-3             0.1.6-1+b1       Qt like interface for the
libexiv2ii  libkipi0                0.1.5-2          library for apps that want 
to
useii  libpng12-0              1.2.15~beta5-3   PNG library - runtime
ii  libqt3-mt               3:3.3.8b-4       Qt GUI Library (Threaded
runtime vii  libstdc++6              4.3-20080219-1   The GNU Standard C++ 
Library v3
ii  libtiff4                3.8.2-7          Tag Image File Format (TIFF)
librahi  libx11-6                2:1.0.3-7        X11 client-side library
ii  libxml2                 2.6.31.dfsg-1    GNOME XML library

Versions of packages kipi-plugins recommends:
ii  imagemagick            7:6.3.7.9.dfsg1-2 image manipulation programs
ii  k3b                    1.0.4-7           A sophisticated KDE CD
burning appii  kdeprint               4:3.5.8.dfsg.1-7  print system for KDE
ii  kmail                  4:3.5.8-1         KDE Email client
ii  konqueror              4:3.5.8.dfsg.1-7  KDE's advanced file manager,
web bii  kooka                  4:3.5.8-2+b1      scanner program for KDE
ii  mpg123                 0.67-1            MPEG layer 1/2/3 audio player
ii  sane-utils             1.0.19-1          API library for scanners --
utilit


_______________________________________________
pkg-kde-extras mailing list
pkg-kde-extras@lists.alioth.debian.org
http://lists.alioth.debian.org/mailman/listinfo/pkg-kde-extras

Reply via email to