> But it'd be very nice if we could have kscope working in KDE 4 too.
>
> Currently kscope depends on libkateinterfaces.so.0 which is part of kate.
> But with Kate from 4.1, that library is not available.
>
> Can you please prepare a kscope package for KDE 4.1 in experimental?

The issue can't be fixed in kscope itself as it needs some library provided by 
kate3 and not kate4, and no kde4 version of kscope has been released yet.

As a temporary solution, you can extract the libkateinterfaces.so.0.0.0 from a 
kate3 debian package and put it in /usr/local/lib as all its deps are provided 
by kdelibs4c2a.

If you use i386, you can do the following (as root) :
  cd /tmp
  wget ftp.debian.org/debian/pool/main/k/kdebase/kate_3.5.9.dfsg.1-5_i386.deb
  ar x kate_3.5.9.dfsg.1-5_i386.deb
  tar xzf data.tar.gz
  cp usr/lib/libkateinterfaces.so.0.0.0 /usr/local/lib
  ldconfig

Let me know if it doesn't have side effects on kscope's stability/features.

Regards
-- 
Xavier Vello




_______________________________________________
pkg-kde-extras mailing list
pkg-kde-extras@lists.alioth.debian.org
http://lists.alioth.debian.org/mailman/listinfo/pkg-kde-extras

Reply via email to