On Monday 19 January 2009, Michael Biebl wrote:
> Does it help if you reload dbus (restart dbus) or reboot your laptop?

No. I rebooted the laptop before I reported the problem.

Additional info
===============
Last kpowersave upgrade was on Tue, Jan 13 2009 09:13:35 +0100:
[UPGRADE] kpowersave 0.7.3-2 -> 0.7.3-3

The dbus upgrade was on Sat, Jan 17 2009 09:19:41 +0100:
[UPGRADE] dbus 1.2.1-4 -> 1.2.1-5
[UPGRADE] dbus-x11 1.2.1-4 -> 1.2.1-5
[UPGRADE] libdbus-1-3 1.2.1-4 -> 1.2.1-5

Before the dbus upgrade I've never had these errors.

I have three occurrences of the error in auth.log:
Jan 18 12:31:40 aragorn dbus-daemon: Rejected send message, 2 matched 
rules; type="method_return", sender=":1.0" (uid=0 pid=3562 
comm="/usr/sbin/hald ") interface="(unset)" member="(unset)" error 
name="(unset)" requested_reply=0 destination=":1.6" (uid=1000 pid=4998 
comm="kpowersave [kdeinit]                              "))
Jan 19 10:31:43 aragorn dbus-daemon: Rejected send message, 2 matched 
rules; type="error", sender=":1.0" (uid=0 pid=3697 
comm="/usr/sbin/hald ") interface="(unset)" member="(unset)" error 
name="org.freedesktop.Hal.Device.UnknownError" requested_reply=0 
destination=":1.6" (uid=1000 pid=5146 comm="kpowersave 
[kdeinit]                              "))
Jan 19 11:47:25 aragorn dbus-daemon: Rejected send message, 2 matched 
rules; type="method_return", sender=":1.0" (uid=0 pid=3469 
comm="/usr/sbin/hald ") interface="(unset)" member="(unset)" error 
name="(unset)" requested_reply=0 destination=":1.6" (uid=1000 pid=4918 
comm="kpowersave [kdeinit]                              "))

Note that the "type" differs.

Looking at my syslog a bit closer I see that:
* the first occurrence was shortly *after* resuming from STR:
Jan 18 12:31:33 aragorn kernel: Back to C!
[...]
Jan 18 12:31:33 aragorn kernel: wlan0: associated
Jan 18 12:31:33 aragorn acpid: client connected from 3691[0:0]
Jan 18 12:31:40 aragorn identd[23783]: started

* the second occurrence is also after return from STR, but is now
  a bit before the identd start:
Jan 19 10:31:43 aragorn kernel: Back to C!
[...]
Jan 19 10:31:43 aragorn kernel: Restarting tasks ... done.
Jan 19 10:31:43 aragorn acpid: client 3825[0:0] has disconnected
Jan 19 10:31:43 aragorn acpid: client connected from 3825[0:0]
Jan 19 10:31:45 aragorn anacron[445]: Anacron 2.3 started on 2009-01-19
Jan 19 10:31:45 aragorn anacron[445]: Will run job `cron.daily' in 5 min.
Jan 19 10:31:45 aragorn anacron[445]: Jobs will be executed sequentially
Jan 19 10:31:50 aragorn identd[1582]: started

* the third occurrence is again after return from STR:
Jan 19 11:47:18 aragorn kernel: Back to C!
[...]
Jan 19 11:47:18 aragorn acpid: client connected from 3616[0:0]
Jan 19 11:47:25 aragorn identd[6605]: started


Here is an overview of all the STRs I've done in the relevant period:
$ grep -h "Back to C" /var/log/syslog.0 /var/log/syslog
Jan 17 09:16:44 aragorn kernel: Back to C! -- before the dbus upgrade
Jan 18 12:31:33 aragorn kernel: Back to C!
Jan 18 12:46:37 aragorn kernel: Back to C! -- no associated error
Jan 19 10:31:43 aragorn kernel: Back to C!
Jan 19 11:47:18 aragorn kernel: Back to C!

The error does not happen on (re)boot [1] or when I dock/undock the 
notebook (i.e. on power status changes).

It seems 100% clear to me that the error must be related to the dbus 
upgrade. I'm afraid I cannot help you much with why.

I'm willing to try to capture the issue using strace if you can tell me 
which process(es) I should attach to (kpowersave, dbus/hal daemons?) and 
what events I should log.

Cheers,
FJP

[1] I've done a fair number of reboots yesterday as I was tracing an X.Org 
bug, and today I upgraded my kernel to 2.6.28.1.



_______________________________________________
pkg-kde-extras mailing list
pkg-kde-extras@lists.alioth.debian.org
http://lists.alioth.debian.org/mailman/listinfo/pkg-kde-extras

Reply via email to