Mark Purcell schreef:
Luk, Martial,

I think I have narrowed down this issue.

digikam tries to load the marble plugins, but they are not shipped in the libmarble package, rather the marble package itself.

The solution is for digikam to Depend on marble, but as a work around, you should be able to install marble (KDE4.2) by hand and digikam should then work.

Could you please confirm if this fixes your issue.
Marble is installed, this is not the issue.  The GDB dump below, confirms
there is an issue: something to do with the undcard. Indeed I confirm
on my laptop, sound is still not working. However I don understand why
Digikam is involved in sound.

Should I involve the Phonon maintainers in this ?

Luc

===========================

Below the GDB dump
======================================================

l...@lanaken:~$ gdb digikam
GNU gdb (GDB) 6.8.50.20090106-cvs-debian
Copyright (C) 2009 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "i486-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
(no debugging symbols found)
(gdb) run
Starting program: /usr/bin/digikam
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[New Thread 0xb31efb90 (LWP 3415)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[New Thread 0xb26bbb90 (LWP 3416)]
[New Thread 0xb1eb1b90 (LWP 3417)]
[Thread 0xb26bbb90 (LWP 3416) exited]
(no debugging symbols found)
[Thread 0xb1eb1b90 (LWP 3417) exited]
[New Thread 0xb1eb1b90 (LWP 3422)]
[New Thread 0xb26bbb90 (LWP 3423)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
digikam(3404) Phonon::KdePlatformPlugin::createBackend: using backend: "GStreamer"
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
virtual bool Phonon::Gstreamer::AudioOutput::setOutputDevice(const Phonon::AudioOutputDevice&) "Cirrus Logic CS4281 (CS4281)" virtual bool Phonon::Gstreamer::AudioOutput::setOutputDevice(const Phonon::AudioOutputDevice&) ("x-phonon:CARD=0,DEV=0", "plughw:CARD=0,DEV=0") virtual bool Phonon::Gstreamer::AudioOutput::setOutputDevice(const Phonon::AudioOutputDevice&) setProperty(device, "x-phonon:CARD=0,DEV=0" ) failed virtual bool Phonon::Gstreamer::AudioOutput::setOutputDevice(const Phonon::AudioOutputDevice&) setProperty(device, "plughw:CARD=0,DEV=0" ) failed virtual bool Phonon::Gstreamer::AudioOutput::setOutputDevice(const Phonon::AudioOutputDevice&) "Cirrus Logic CS4281 (CS4281)" virtual bool Phonon::Gstreamer::AudioOutput::setOutputDevice(const Phonon::AudioOutputDevice&) ("x-phonon:CARD=0,DEV=0", "plughw:CARD=0,DEV=0") virtual bool Phonon::Gstreamer::AudioOutput::setOutputDevice(const Phonon::AudioOutputDevice&) setProperty(device, "x-phonon:CARD=0,DEV=0" ) failed virtual bool Phonon::Gstreamer::AudioOutput::setOutputDevice(const Phonon::AudioOutputDevice&) setProperty(device, "plughw:CARD=0,DEV=0" ) failed virtual bool Phonon::Gstreamer::AudioOutput::setOutputDevice(const Phonon::AudioOutputDevice&) "default"

Program received signal SIGSEGV, Segmentation fault.
0xb5812677 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
(gdb) thread apply all backtrace

Thread 6 (Thread 0xb26bbb90 (LWP 3423)):
#0  0xb7fe1424 in __kernel_vsyscall ()
#1 0xb5125fb5 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i686/cmov/libpthread.so.0
#2  0xb5520f2d in pthread_cond_wait () from /lib/i686/cmov/libc.so.6
#3 0xb5709852 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4 #4 0xb7228bda in Digikam::LoadSaveThread::run() () from /usr/lib/libdigikamcore.so.1
#5  0xb570883e in ?? () from /usr/lib/libQtCore.so.4
#6  0xb51224e5 in start_thread () from /lib/i686/cmov/libpthread.so.0
#7  0xb551210e in clone () from /lib/i686/cmov/libc.so.6

Thread 5 (Thread 0xb1eb1b90 (LWP 3422)):
#0  0xb7fe1424 in __kernel_vsyscall ()
#1 0xb5125fb5 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i686/cmov/libpthread.so.0
#2  0xb5520f2d in pthread_cond_wait () from /lib/i686/cmov/libc.so.6
#3 0xb5709852 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4 #4 0xb7228bda in Digikam::LoadSaveThread::run() () from /usr/lib/libdigikamcore.so.1
#5  0xb570883e in ?? () from /usr/lib/libQtCore.so.4
#6  0xb51224e5 in start_thread () from /lib/i686/cmov/libpthread.so.0
#7  0xb551210e in clone () from /lib/i686/cmov/libc.so.6

Thread 2 (Thread 0xb31efb90 (LWP 3415)):
#0  0xb7fe1424 in __kernel_vsyscall ()
#1 0xb5125fb5 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i686/cmov/libpthread.so.0
#2  0xb5520f2d in pthread_cond_wait () from /lib/i686/cmov/libc.so.6
#3 0xb5709852 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/libQtCore.so.4
#4  0x0828e879 in ?? ()
#5  0xb570883e in ?? () from /usr/lib/libQtCore.so.4
#6  0xb51224e5 in start_thread () from /lib/i686/cmov/libpthread.so.0
#7  0xb551210e in clone () from /lib/i686/cmov/libc.so.6

Thread 1 (Thread 0xb4841700 (LWP 3404)):
#0 0xb5812677 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /usr/lib/libQtCore.so.4
#1  0xb7f87423 in ?? () from /usr/lib/libphonon.so.4
#2  0x00000000 in ?? ()
(gdb)





begin:vcard
fn:Luc Castermans
n:Castermans;Luc
email;internet:luc.casterm...@gmail.com
x-mozilla-html:FALSE
version:2.1
end:vcard

_______________________________________________
pkg-kde-extras mailing list
pkg-kde-extras@lists.alioth.debian.org
http://lists.alioth.debian.org/mailman/listinfo/pkg-kde-extras

Reply via email to