Package: digikam
Version: 2:0.9.5-1
Severity: grave
Justification: renders package unusable

Hi, 

I wanted to install digikam 0.9.5 on my MacBook, but I noticed it is not
availabe on amd64 yet. The build on the buildd failed with

In file included from 
/build/buildd/digikam-0.9.5/./digikam/digikam/albumwidgetstack.cpp:41,
                 from libdigikam_la.all_cpp.cpp:21:
/build/buildd/digikam-0.9.5/./digikam/digikam/albumwidgetstack.h: At global 
scope:
/build/buildd/digikam-0.9.5/./digikam/digikam/albumwidgetstack.h:38: warning: 
declaration 'class KURL::List' does not declare anything
/bin/sh ../../libtool --silent --tag=CXX   --mode=link g++  -fno-tree-pre 
-Wno-long-long -Wundef -ansi -D_XOPEN_SOURCE=500 -D_BSD_SOURCE -Wcast-align 
-Wchar-subscripts -Wall -W -Wpointer-arith -DNDEBUG -DNO_DEBUG -O2 -g -O2 -g 
-Wall -O2 -Wformat-security -Wmissing-format-attribute -Wno-non-virtual-dtor 
-fno-exceptions -fno-check-new -fno-common -DQT_CLEAN_NAMESPACE 
-DQT_NO_ASCII_CAST -DQT_NO_STL -DQT_NO_COMPAT -DQT_NO_TRANSLATION 
-DQT_CLEAN_NAMESPACE  -lkexiv2   -L/usr/share/qt3/lib      -no-undefined 
-Wl,--as-needed -o libdigikam.la -rpath /usr/lib libdigikam_la.all_cpp.lo  
-lsqlite3    -lkio -lkabc -lkhtml -lkipi   -lkexiv2   -lkutils 
../../digikam/libs/sqlite2/libsqlite2.la 
../../digikam/libs/thumbbar/libthumbbar.la 
../../digikam/libs/themeengine/libthemeengine.la 
../../digikam/libs/widgets/libwidgets.la 
../../digikam/libs/dialogs/libdialog.la 
../../digikam/libs/jpegutils/libjpegutils.la ../../digikam/libs/dimg/libdimg.la 
../../digikam/libs/imageproperties/libimageproperti
 esdigikam.la ../../digikam/libs/threadimageio/libthreadimageio.la 
../../digikam/libs/greycstoration/libgreycstoration.la 
../../digikam/utilities/batch/libbatch.la 
../../digikam/utilities/slideshow/libslideshow.la 
../../digikam/utilities/cameragui/libcameragui.la 
../../digikam/utilities/imageeditor/canvas/libdimgcanvas.la 
../../digikam/utilities/imageeditor/editor/libdimgeditor.la 
../../digikam/utilities/setup/libsetup.la 
../../digikam/utilities/lighttable/liblighttable.la 
/usr/bin/ld: cannot find -licui18n
collect2: ld returned 1 exit status
make[4]: *** [libdigikam.la] Error 1
make[4]: Leaving directory 
`/build/buildd/digikam-0.9.5/obj-x86_64-linux-gnu/digikam/digikam'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory 
`/build/buildd/digikam-0.9.5/obj-x86_64-linux-gnu/digikam'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/build/buildd/digikam-0.9.5/obj-x86_64-linux-gnu'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/build/buildd/digikam-0.9.5/obj-x86_64-linux-gnu'
make: *** [debian/stamp-makefile-build] Error 2
dpkg-buildpackage: failure: debian/rules build gave error exit status 2
******************************************************************************
Build finished at 20090317-1137
FAILED [dpkg-buildpackage died]
Purging chroot-unstable/build/buildd/digikam-0.9.5

The full log can be found at 
https://buildd.debian.org/fetch.cgi?pkg=digikam;ver=2%3A0.9.5-1;arch=amd64;stamp=1237290295

I did not yet have time to have a deeper look into this problem
or to try the build myself :-(

With best wishes,

Wolfi


-- System Information:
Debian Release: squeeze/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'stable')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.29-1-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Attachment: signature.asc
Description: Digital signature

_______________________________________________
pkg-kde-extras mailing list
pkg-kde-extras@lists.alioth.debian.org
http://lists.alioth.debian.org/mailman/listinfo/pkg-kde-extras

Reply via email to