Your message dated Sat, 29 Aug 2009 09:45:34 +0100
with message-id <1251535534.594699.5896.nullmai...@kmos.homeip.net>
and subject line Package libsynaptics has been removed from Debian
has caused the Debian Bug report #505077,
regarding FTBFS with GCC 4.4: missing #include
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
505077: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=505077
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Package: libsynaptics
Version: 0.14.6c-2
User: debian-...@lists.debian.org
Usertags: ftbfs-gcc-4.4
Tags: patch

Your package fails to build with the upcoming GCC 4.4.  Version 4.4
has not been released yet but I'm building with a snapshot in order
to find errors and give people an advance warning.

GCC 4.4 cleaned up some more C++ headers.  You always have to #include
headers directly and cannot rely for things to be included indirectly.

You can reproduce this problem with gcc-snapshot from unstable.

> Automatic build of libsynaptics_0.14.6c-2 on em64t by sbuild/amd64 0.53
...
>  g++ -DPACKAGE_NAME=\"\" -DPACKAGE_TARNAME=\"\" -DPACKAGE_VERSION=\"\" 
> -DPACKAGE_STRING=\"\" -DPACKAGE_BUGREPORT=\"\" -DPACKAGE=\"libsynaptics\" 
> -DVERSION=\"0.14.6c\" -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 
> -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 
> -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 
> -DHAVE_DLFCN_H=1 -I. -g -O2 -g -Wall -O2 -c pad.cpp  -fPIC -DPIC -o 
> .libs/pad.o
> pad.cpp: In member function 'std::string Synaptics::Pad::intVerToStrVer(int)':
> pad.cpp:109: error: 'sprintf' was not declared in this scope
> pad.cpp: In member function 'bool Synaptics::Pad::detectDriverVersion()':
> pad.cpp:176: error: 'perror' was not declared in this scope
> pad.cpp: In member function 'void Synaptics::Pad::init()':
> pad.cpp:575: error: 'perror' was not declared in this scope
> make[1]: *** [pad.lo] Error 1

--- pad.cpp~    2008-11-09 08:11:42.000000000 +0000
+++ pad.cpp     2008-11-09 08:11:48.000000000 +0000
@@ -2,6 +2,7 @@
 #include "synparam.h"
 #include "pad.h"
 #include <pthread.h>
+#include <stdio.h>
 #include <stdlib.h>
 #include <unistd.h>
 #include <sys/shm.h>

-- 
Martin Michlmayr
http://www.cyrius.com/



--- End Message ---
--- Begin Message ---
Version: 0.14.6c-2+rm

You filled the bug http://bugs.debian.org/505077 in Debian BTS
against the package libsynaptics. I'm closing it at *unstable*, but it will
remain open for older distributions.

For more information about this package's removal, read
http://bugs.debian.org/542605. That bug might give the reasons why
this package was removed and suggestions of possible replacements.

Don't hesitate to reply to this mail if you have any question.

Thank you for your contribution to Debian.

--
Marco Rodrigues


--- End Message ---
_______________________________________________
pkg-kde-extras mailing list
pkg-kde-extras@lists.alioth.debian.org
http://lists.alioth.debian.org/mailman/listinfo/pkg-kde-extras

Reply via email to