Your message dated Sun, 27 Dec 2009 09:36:15 +0000
with message-id <>
and subject line Package kpowersave has been removed from Debian
has caused the Debian Bug report #519313,
regarding kpowersave: Recognises 2nd Battery but not if inserted during S4
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact

Debian Bug Tracking System
Contact with problems
--- Begin Message ---
Package: kpowersave
Version: 0.7.3-3
Severity: normal


Recently kpowersave had functionality updated such that it became 
capable of dynamically recognising multiple batteries that have been 
inserted into a machine.  Just some feedback there, this does work well.

My Thinkpad X40 has two battery options which can be fitted at the same 
time or idependantly and kpowersave does a very good job of working out 
when one or both have been inserted or removed.

What does confuse it though is say if I boot up the machine fresh with 
one battery installed and hibernate the machine (S4).  Now if I 
installed the 2nd battery and resume the machine, kpowersave will not 
show this second battery has been inserted.

I have tried exiting kpowersave and starting it again and this has now 
effect.  I have also tried invokeing a restart of HAL which succeeds but 
doesn't seem to help, even if I close kpowersave and start it again 

It is difficult to ascertain if this likely to be a kpowersave bug or a 
HAL issue.  If on the basis of what I have described (and your knowledge 
of how kpowersave works in respect of what HAL tells it) you reassign 
this bug to the HAL package, then so be it.

-- System Information:
Debian Release: squeeze/sid
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: i386 (i686)

Kernel: Linux 2.6.26-1-686 (SMP w/1 CPU core)
Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages kpowersave depends on:
ii  hal                 0.5.11-8             Hardware Abstraction Layer
ii  kdelibs4c2a         4:3.5.10.dfsg.1-1+b1 core libraries and binaries for al
ii  libc6               2.9-4                GNU C Library: Shared libraries
ii  libdbus-1-3         1.2.12-1             simple interprocess messaging syst
ii  libdbus-qt-1-1c2    0.62.git.20060814-2  simple interprocess messaging syst
ii  libgcc1             1:4.3.3-3            GCC support library
ii  libhal1             0.5.11-8             Hardware Abstraction Layer - share
ii  libstdc++6          4.3.3-3              The GNU Standard C++ Library v3
ii  libxext6            2:1.0.4-1            X11 miscellaneous extension librar
ii  libxss1             1:1.1.3-1            X11 Screen Saver extension library
ii  libxtst6            2:1.0.3-1            X11 Testing -- Resource extension 

kpowersave recommends no packages.

kpowersave suggests no packages.

-- no debconf information

--- End Message ---
--- Begin Message ---
Version: 0.7.3-5+rm

You filled the bug in Debian BTS
against the package kpowersave. I'm closing it at *unstable*, but it will
remain open for older distributions.

For more information about this package's removal, read That bug might give the reasons why
this package was removed and suggestions of possible replacements.

Don't hesitate to reply to this mail if you have any question.

Thank you for your contribution to Debian.

Marco Rodrigues

--- End Message ---
pkg-kde-extras mailing list

Reply via email to