Package: kmplayer
Version: 1:0.11.2a-1
Severity: normal

--- Please enter the report below this line. ---

Hello

I have the following file on my system (with UTF-8 é char):

  Winx Club - S04E06 - Une fée en danger.mkv

When I try to run kmplayer on this file, kmplayer shows only a black screen 
(but does not hang). STDOUT shows:


$ kmplayer Winx\ Club\ -\ S04E06\ -\ Une\ fée\ en\ danger.mkv 
mplayer -wid 69206702 -slave -vo xv -ao alsa -framedrop -contrast 0 -
brightness 0 -hue 0 -saturation 0 /mnt/video3/domi/dessins-animes/Winx 
Club/Winx Club - S04E06 - Une fée en danger.mkv -identify    

Note that the 'é' is garbled.

On the other hand, running kmplayer with LC_ALL=C will work:

$ LC_ALL=C kmplayer Winx\ Club\ -\ S04E06\ -\ Une\ fée\ en\ danger.mkv
mplayer -wid 69206699 -slave -vo xv -ao alsa -framedrop -contrast 0 -
brightness 0 -hue 0 -saturation 0 /mnt/video3/domi/dessins-animes/Winx 
Club/Winx Club - S04E06 - Une f�e en danger.mkv -identify

If I set konsole to decode ISO-8859-15, I get this display:

$ LC_ALL=C kmplayer Winx\ Club\ -\ S04E06\ -\ Une\ fée\ en\ danger.mkv
mplayer -wid 69206699 -slave -vo xv -ao alsa -framedrop -contrast 0 -
brightness 0 -hue 0 -saturation 0 /mnt/video3/domi/dessins-animes/Winx 
Club/Winx Club - S04E06 - Une fée en danger.mkv -identify

$ kmplayer Winx\ Club\ -\ S04E06\ -\ Une\ fée\ en\ danger.mkv
mplayer -wid 69206699 -slave -vo xv -ao alsa -framedrop -contrast 0 -
brightness 0 -hue 0 -saturation 0 /mnt/video3/domi/dessins-animes/Winx 
Club/Winx Club - S04E06 - Une fée en danger.mkv -identify

I guess that kmplayer has some bugs regarding UTF-8

All the best

--- System information. ---
Architecture: amd64
Kernel:       Linux 2.6.32-4-amd64

Debian Release: squeeze/sid
  990 unstable        localhost 
  500 testing         localhost 
  500 instable        localhost 
    1 experimental    localhost 

--- Package information. ---
Depends                  (Version) | Installed
==================================-+-=============
kdebase-runtime       (>= 4:4.3.0) | 4:4.3.4-2
kdelibs5              (>= 4:4.3.4) | 4:4.3.4-3
libatk1.0-0            (>= 1.20.0) | 1.28.0-1
libc6                   (>= 2.2.5) | 2.10.2-6
libcairo2               (>= 1.2.4) | 1.8.10-3
libdbus-1-3             (>= 1.0.2) | 1.2.24-1
libdbus-glib-1-2         (>= 0.78) | 0.84-1
libfontconfig1          (>= 2.8.0) | 2.8.0-2
libfreetype6            (>= 2.2.1) | 2.3.11-1
libgcc1               (>= 1:4.1.1) | 1:4.4.3-5
libglib2.0-0           (>= 2.16.0) | 2.22.4-1
libgtk2.0-0             (>= 2.8.0) | 2.18.9-2
libpango1.0-0          (>= 1.14.0) | 1.26.2-2
libphonon4            (>= 4:4.2.0) | 4:4.5.3-4
libqt4-dbus           (>= 4:4.5.3) | 4:4.5.3-4
libqt4-network        (>= 4:4.5.3) | 4:4.5.3-4
libqt4-qt3support     (>= 4:4.5.3) | 4:4.5.3-4
libqt4-svg            (>= 4:4.5.3) | 4:4.5.3-4
libqt4-xml            (>= 4:4.5.3) | 4:4.5.3-4
libqtcore4            (>= 4:4.5.3) | 4:4.5.3-4
libqtgui4             (>= 4:4.5.3) | 4:4.5.3-4
libstdc++6              (>= 4.1.1) | 4.4.3-5
libx11-6                    (>= 0) | 2:1.3.3-2
phonon                (>= 4:4.5.2) | 4:4.5.3-4
dbus-x11                           | 1.2.24-1
libxine1-x                         | 1.1.18.1-1+b1


Package's Recommends field is empty.

Suggests       (Version) | Installed
========================-+-===========
ffmpeg                   | 5:0.5.1+svn20100321-0.0
vdr                      | 1.6.0-15
xawtv                    | 
konqueror                | 4:4.3.4-1
mplayer                  | 1:1.0.rc2svn20100325-0.0







_______________________________________________
pkg-kde-extras mailing list
pkg-kde-extras@lists.alioth.debian.org
http://lists.alioth.debian.org/mailman/listinfo/pkg-kde-extras

Reply via email to