Your message dated Thu, 22 Apr 2010 16:46:19 +0200
with message-id <201004221646.21197.did...@raboud.com>
and subject line Re: #578114: kdebluetooth ceased recognising dongle after 
upgrade
has caused the Debian Bug report #578114,
regarding kdebluetooth ceased recognising dongle after upgrade
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact ow...@bugs.debian.org
immediately.)


-- 
578114: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=578114
Debian Bug Tracking System
Contact ow...@bugs.debian.org with problems
--- Begin Message ---
Package: kdebluetooth
Version: 1.0~beta8-6+b1
Severity: grave
Justification: renders package unusable


I've upgraded some libs in my system (KDE 3.5) and my KDE system ceased 
recognizing the Bluetooth dongle.
There is no external sign of the error, but kblueplugd tells what is happening:

$ kblueplugd
Traceback (most recent call last):
  File "/usr/bin/kblueplugd", line 35, in <module>
    if len(manager.ListAdapters()):
  File "/usr/lib/pymodules/python2.5/dbus/proxies.py", line 68, in __call__
    return self._proxy_method(*args, **keywords)
  File "/usr/lib/pymodules/python2.5/dbus/proxies.py", line 140, in __call__
    **keywords)
  File "/usr/lib/pymodules/python2.5/dbus/connection.py", line 630, in 
call_blocking
    message, timeout)
dbus.exceptions.DBusException: org.freedesktop.DBus.Error.UnknownMethod: Method 
"ListAdapters" with signature "" on interface "org.bluez.Manager" doesn't exist

Problem is NOT the access rights, since user is in groups netdev and bluetooth

-- System Information:
Debian Release: squeeze/sid
  APT prefers testing
  APT policy: (990, 'testing'), (500, 'unstable'), (500, 'stable')
Architecture: i386 (i686)

Kernel: Linux 2.6.32-3-686 (SMP w/2 CPU cores)
Locale: LANG=es_ES.UTF-8, LC_CTYPE=es_ES.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages kdebluetooth depends on:
ii  bluez-utils          4.60-1              Transitional package
ii  kdelibs4c2a          4:3.5.10.dfsg.1-3   core libraries and binaries for al
ii  libacl1              2.2.49-2            Access control list shared library
ii  libart-2.0-2         2.3.20-2            Library of functions for 2D graphi
ii  libattr1             1:2.4.44-1          Extended attribute shared library
ii  libaudio2            1.9.2-3             Network Audio System - shared libr
ii  libbluetooth3        4.60-1              Library to use the BlueZ Linux Blu
ii  libc6                2.10.2-6            Embedded GNU C Library: Shared lib
ii  libdbus-1-3          1.2.1-5+lenny1      simple interprocess messaging syst
ii  libdbus-qt-1-1c2     0.62.git.20060814-2 simple interprocess messaging syst
ii  libfam0              2.7.0-13.3+lenny1   Client library to control the FAM 
ii  libfontconfig1       2.8.0-2             generic font configuration library
ii  libfreetype6         2.3.7-2+lenny1      FreeType 2 font engine, shared lib
ii  libgcc1              1:4.4.3-5           GCC support library
ii  libice6              2:1.0.6-1           X11 Inter-Client Exchange library
ii  libidn11             1.15-2              GNU Libidn library, implementation
ii  libjpeg62            6b-14               The Independent JPEG Group's JPEG 
ii  libkbluetooth0       1.0~beta8-6+b1      Bluetooth library for KDE
ii  libopenobex1         1.3+cvs20070425-2   OBEX protocol library
ii  libpng12-0           1.2.27-2+lenny2     PNG library - runtime
ii  libqt3-mt            3:3.3.8b-5+b1       Qt GUI Library (Threaded runtime v
ii  libsm6               2:1.1.1-1           X11 Session Management library
ii  libstdc++6           4.4.3-5             The GNU Standard C++ Library v3
ii  libx11-6             2:1.3.3-2           X11 client-side library
ii  libxcursor1          1:1.1.9-1           X cursor management library
ii  libxext6             2:1.1.1-3           X11 miscellaneous extension librar
ii  libxft2              2.1.12-3            FreeType-based font drawing librar
ii  libxi6               2:1.3-4             X11 Input extension library
ii  libxinerama1         2:1.0.3-2           X11 Xinerama extension library
ii  libxrandr2           2:1.3.0-3           X11 RandR extension library
ii  libxrender1          1:0.9.5-2           X Rendering Extension client libra
ii  libxt6               1:1.0.7-1           X11 toolkit intrinsics library
ii  python-qt4           4.7.2-1             Python bindings for Qt4
ii  python-qt4-dbus      4.7.2-1             DBus Support for PyQt4
ii  zlib1g               1:1.2.3.4.dfsg-3    compression library - runtime

kdebluetooth recommends no packages.

Versions of packages kdebluetooth suggests:
ii  python                        2.5.2-3    An interactive high-level object-o

-- no debconf information



--- End Message ---
--- Begin Message ---
Le jeudi 22 avril 2010 16:33:50 Noel David Torres Taño, vous avez écrit :
> I'm using lenny, with some packages cherrypicked to squeeze.

Hi,

please keep the bug (578...@bugs.debian.or) CCed.

Mixing releases is _not_ supported: you can't expect (from Debian) to get a 
working system if you mix libraries and binaries from Lenny and Squeeze. I'm 
hereby closing this bug, because we can't support this use case: there are 
backports if you really need more up2date packages.

> Will that force me to upgrade all to KDE 4 ? I want to avoid that if I can.
> I'm not yet assured of it stability, and I'm assured of its high
> requirements. Moreover, I use different wallpapers for virtual desktops,
> wich is not yet solved (activities is not a solution).

There are two things: Debian and KDE. On the Debian side, you can't mix 
releases 
as you are doing: either stick with pure Lenny (+ eventually backports) or go 
to 
Squeeze.

Going to Squeeze fully implies that you have to migrate to KDE4: you can't get 
the stability of Lenny (with KDE 3.5) and the bleeding-edgyness of Squeeze at 
the same time.

> Thanks for the answer. I will try 1:0.4.2-2 as soon as you answer me the
> previous question.
> 
> Noel
> er Envite

Please reopen this bug if you can reproduce this bug either on a pure Lenny or 
on a pure Squeeze.

Cheers, 

OdyX

-- 
Didier Raboud, proud Debian Maintainer (DM).
CH-1020 Renens
did...@raboud.com

Attachment: signature.asc
Description: This is a digitally signed message part.


--- End Message ---
_______________________________________________
pkg-kde-extras mailing list
pkg-kde-extras@lists.alioth.debian.org
http://lists.alioth.debian.org/mailman/listinfo/pkg-kde-extras

Reply via email to